Running Spyder

34 views
Skip to first unread message

Russ Abbott

unread,
May 24, 2021, 6:18:14 PMMay 24
to Anaconda - Public
Hi I'm just starting with Anaconda and Navigator. Going through " Getting started with Anaconda" I'm at the point at which I'm supposed to start Spyder. When I click the Spyder tile in the navigator window, some activity appears at the bottom right of the window. But then it stops and Spyder had not started.  (I don't see a new Spyder window, and Spyder isn't listed in the Task list. (I'm on Windows.) When I click Spyder in the Windows menu at the left of the main screen, nothing happens. 

What am I missing?

Thanks.

Russ Abbott

unread,
May 24, 2021, 6:21:58 PMMay 24
to Anaconda - Public, Russ Abbott
P.S. When I click the Jupyter tile, it starts up properly.

Russ Abbott

unread,
May 24, 2021, 6:31:15 PMMay 24
to Anaconda - Public, Russ Abbott
When I attempt to run Spyder from the Anaconda Prompt, I get quite a few messages about files being loaded, but at the end I get this error.
     `OSError: [WinError 193] %1 is not a valid Win32 application`

rjford99

unread,
May 25, 2021, 1:38:30 PMMay 25
to Anaconda - Public, russ....@gmail.com
Did you download the Anaconda 64 bit version?
There are similar known problems with Navigator and the latest Anaconda versions for Windows 10.
This is being worked on.
If you install the November 2020 Anaconda you should be OK.

Russ Abbott

unread,
Jun 3, 2021, 12:05:22 PMJun 3
to Anaconda - Public, fordr...@gmail.com, Russ Abbott
Sorry to take so long to reply. (I'm using Jupyter Lab, but I wanted to try Spyder.) I'm surprised a version of Anaconda with such obvious bugs would be released.
Reply all
Reply to author
Forward
0 new messages