Sqoop export - Date issue with Oracle

Showing 1-2 of 2 messages
Sqoop export - Date issue with Oracle nago 1/17/12 8:16 AM
Hello Friends,

I am trying to do sqooping the data from HDFC file to Oracle (10.2g)
table.
I could do sqooping if no date value in the file.

But, if i have date value in the file , it throws exception that
"Timestamp format must be yyyy-mm-dd hh:mm:ss[.fffffffff] ".
what is the problem ?What should i do , so that i can avoid this
issue ?


This the sqoop command i have :
--------------------------------------------------
 sqoop export  --connect jdbc:oracle:thin:@//16.48.140.88/aggint --
username NAGO  -P  --table WD1   --export-dir /services/location/
mapskpi/reporting/data/test/ --fields-terminated-by ,

data in the file will look alike:
----------------------------------------
2012-01-06,2012,1,1,258665,2012-01-13

Oracle Table WD1:
--------------------------
FI_DT        DATE
YR        NUMBER(38)
CNT1      NUMBER(38)
CNT2      NUMBER(38)
CNT3      NUMBER(38)
SE_DT      DATE

can you please help ?

Thanks
nago
RE: [sqoop-user] Sqoop export - Date issue with Oracle David Robson 1/17/12 3:22 PM
Hi Nago,

I just tried this out with a file the same as you specified and got the same error as you.

The good news is when I used the Quest Data Connector for Oracle and Hadoop it worked fine - so perhaps you could use that instead?

You can download it from here: http://toadforcloud.com/entry.jspa?categoryID=677&externalID=4298
Source code is available here under Apache 2.0 license: https://github.com/QuestSoftwareTCD/OracleSQOOPconnector

Let us know if this resolves your issue.

Regards,

David

Hello Friends,

Thanks
nago

--
NOTE: The mailing list sqoop...@cloudera.org is deprecated in favor of Apache Sqoop mailing list sqoop...@incubator.apache.org. Please subscribe to it by sending an email to incubator-sqoop-user-subscribe@apache.org.