ckan datapusher error

14 views
Skip to first unread message

Devanjan Bhattacharya

unread,
Nov 5, 2022, 8:46:58 PM11/5/22
to CKAN Development Discussions
hi all,
i installed ckan 2.9 on ubuntu 20.04 as package install. but on activating datapusher in ckan.ini it started giving internal server error 500 while adding any file to datastore and no data gets added. 

in the datapusher log it shows:

Traceback (most recent call last):
  File "/etc/ckan/datapusher/datapusher.wsgi", line 2, in <module>
    import ckanserviceprovider.web as web
  File "/usr/lib/ckan/datapusher/lib/python3.8/site-packages/ckanserviceprovider/web.py", line 13, in <module>
    import flask_login as flogin
  File "/usr/lib/ckan/datapusher/lib/python3.8/site-packages/flask_login/_init_.py", line 16, in <module>
    from .login_manager import LoginManager
  File "/usr/lib/ckan/datapusher/lib/python3.8/site-packages/flask_login/login_manager.py", line 24, in <module>
    from .utils import (login_url as make_login_url, _create_identifier,
  File "/usr/lib/ckan/datapusher/lib/python3.8/site-packages/flask_login/utils.py", line 13, in <module>
    from werkzeug.security import safe_str_cmp
ImportError: cannot import name 'safe_str_cmp' from 'werkzeug.security' (/usr/lib/ckan/datapusher/lib/python3.8/site-packages/werkzeug/security.py)
unable to load app 0 (mountpoint='') (callable not found or import error)
* no app loaded. going in full dynamic mode *
spawned uWSGI master process (pid: 17178😎
spawned uWSGI worker 1 (pid: 171793, cores: 1)
spawned uWSGI http 1 (pid: 171794)
--- no python application found, check your startup logs for errors ---

I have tried with different versions of werkzeug older as well as latest with versions of flask as well but same error persists.
What could be causing this?  Any help is greatly appreciated! thanks!
Reply all
Reply to author
Forward
0 new messages