Is up to date and known to work on Windows?

Skip to first unread message

Jukka Jylänki

Jan 19, 2022, 4:05:46 AM1/19/22
to web-transport-dev
Hi all,

I am experimenting with WebTransport to integrate its use into a WebAssembly program.

Before getting to play with developing the WebAssembly integration part, I tried following the getting started steps at

(that seems to be the best/only(?) current source today for a getting started resource for developing both a server and a client? If there are others that would be useful, please let me know)

though I run into somewhat odd issues that suggest that maybe the sample has fallen out of date, or maybe things aren't tested to be working on Windows?

The main issue is that latest Chrome Canary and Chromium don't seem to support the command line flag --ignore-certificate-errors-spki-list= that is requested to be used on step 4.

Attempting to ignore that issue and e.g. using live site SSL certificates instead of
self-signed ones does not seem to fare better, but I run into connection issues.

I wrote up my experience to an issue at

If anyone has successfully used the example and would be able to point me out where I am going wrong, that would be much appreciated!


Yutaka Hirano

Jan 19, 2022, 7:52:26 AM1/19/22
to Jukka Jylänki, web-transport-dev
Thank you for using WebTransport!

I replied at the GitHub thread.

I know another working server: web-platform-test server.
Here is a document that describes how to run the webtransport server with WPT.

Hope this helps,


You received this message because you are subscribed to the Google Groups "web-transport-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
To view this discussion on the web visit
Reply all
Reply to author
0 new messages