Requiring the 10.15.1 SDK

25 views
Skip to first unread message

Avi Drissman

unread,
Jun 24, 2020, 10:11:48 PM6/24/20
to Chromium-dev, Chromium Embedders, jaho...@nvidia.com
In order to land https://crrev.com/c/2238504 with even better web platform awesomeness, Chromium will soon officially require the 10.15.1 SDK. We already require the 10.15 SDK, so this should be no big deal.

If you work at Google, no worries, as that version of the SDK is already included in the hermetic toolchain so you already have it. If you don't, please make sure you're running at least Xcode 11.2.

Please email me if this will be an issue for you.

Thanks you,

Avi

Marshall Greenblatt

unread,
Jul 8, 2020, 1:30:13 PM7/8/20
to Avi Drissman, Chromium-dev, Chromium Embedders, jaho...@nvidia.com
Hi Avi,

It looks like your linked change landed in 86.0.4184.0. Will the 10.15.1 SDK be required for M85 as well?

Thanks,
Marshall

--
You received this message because you are subscribed to the Google Groups "Chromium Embedders" group.
To unsubscribe from this group and stop receiving emails from it, send an email to embedder-dev...@chromium.org.
To view this discussion on the web visit https://groups.google.com/a/chromium.org/d/msgid/embedder-dev/CACWgwAZpGxL2P35jWsvFNZuyXKskNab%2BFYxL%2Bp%2BBtPR%3D-2niqA%40mail.gmail.com.

Avi Drissman

unread,
Jul 8, 2020, 1:37:59 PM7/8/20
to Marshall Greenblatt, Chromium-dev, Chromium Embedders, jaho...@nvidia.com
The change I linked is the only one that I'm aware of that requires the 10.15.1 SDK, so you should be in the clear for M85. However, I can't guarantee it. When Chromium moved to require the 10.15 SDK, internally Google updated to the 10.15.1 SDK (as that was the one in the most recent Xcode) and so it's possible that 10.15.1-isms snuck in. A quick search of the SDK for "10.15.1" finds only stuff that I don't believe Chromium uses, though.

Avi

Reply all
Reply to author
Forward
0 new messages