| Auto-Submit | +1 |
| Commit-Queue | +1 |
| Inspect html for hidden footers to help with email filtering. To unsubscribe visit settings. |
| Auto-Submit | +1 |
| Commit-Queue | +1 |
| Inspect html for hidden footers to help with email filtering. To unsubscribe visit settings. |
<devtools-data-grid mode='dynamic-rows' striped name=${Please wrap in `// clang-format off/on` and format manually.
This is rather hard to read.
${UI.Widget.widget(SourceFrame.JSONView.CollapsedJsonView, {`const {widget} = UI.Widget` and simply `widget()` here for brevity.
In this specific case it is fine, but I'd like to avoid setting a bad example.
export class CollapsedJsonView extends UI.Widget.VBox {What makes it "collapsed"?
Why do we need this wrapper? The JSONView is a widget itself, cant we instantiate it directly?
| Inspect html for hidden footers to help with email filtering. To unsubscribe visit settings. |
| Auto-Submit | +0 |
| Commit-Queue | +1 |
<devtools-data-grid mode='dynamic-rows' striped name=${Please wrap in `// clang-format off/on` and format manually.
This is rather hard to read.
Done
${UI.Widget.widget(SourceFrame.JSONView.CollapsedJsonView, {`const {widget} = UI.Widget` and simply `widget()` here for brevity.
In this specific case it is fine, but I'd like to avoid setting a bad example.
Done
export class CollapsedJsonView extends UI.Widget.VBox {What makes it "collapsed"?
Why do we need this wrapper? The JSONView is a widget itself, cant we instantiate it directly?
We want JSONView to be collapsed by default, hence the name xp
I think we would need to add additional setters in JSONView, update constructor, make `parsedJSON` not `readonly`. And since we use a same pattern for SearchableJsonView to create widgets, I added this wrapper. But if you prefer making the changes in JSONView itself, I can do that.
| Inspect html for hidden footers to help with email filtering. To unsubscribe visit settings. |
export class CollapsedJsonView extends UI.Widget.VBox {Samiya CaurWhat makes it "collapsed"?
Why do we need this wrapper? The JSONView is a widget itself, cant we instantiate it directly?
We want JSONView to be collapsed by default, hence the name xp
I think we would need to add additional setters in JSONView, update constructor, make `parsedJSON` not `readonly`. And since we use a same pattern for SearchableJsonView to create widgets, I added this wrapper. But if you prefer making the changes in JSONView itself, I can do that.
We use this pattern above because we need to extend SearchbleView.
You don't need to add setters, although you are welcome to add them.
You can instantiate using a second `widget` overload, like `widger(e => new JSONView(e, new ParsedJSON(obj, '', '')))`.
Might need propagate element through the JSONView constructor to the base class, but that's the only thing needed.
| Inspect html for hidden footers to help with email filtering. To unsubscribe visit settings. |