I think that's a good point, but I would make a distinction between the feature and the implementation: We don't like the std implementation of some of the features, but we're still copying the basic design, with the original intent being that these are just backported std features that won't need duplicate implementations someday. If there's no intent to switch to the std version, I'd argue they should at least be spelled differently enough to highlight any differences in behavior.
Even in the case of something like absl::optional vs. std::optional, where there's a security objection to switching the libc++ version, keeping both is clearly suboptimal, and last I heard, there's active work going on to address that.
Anyway, for these features specifically, I agree that those should be resolved on the other thread. Hopefully there won't be any. :-)