Extracting VoiceIsolationHandler out of AudioProcessorHandler
The creation of VoiceIsolation should be handled in one place only. This change
consolidates the creation in the InputController as a previous step to move
everything inside VoiceIsolationHandler.
| Inspect html for hidden footers to help with email filtering. To unsubscribe visit settings. |
Extracting VoiceIsolationHandler out of AudioProcessorHandler
The creation of VoiceIsolation should be handled in one place only. This change
consolidates the creation in the InputController as a previous step to move
everything inside VoiceIsolationHandler.
Could you rephrase? I'm not sure I understand what is being said. (VoiceIsolation is created in one place)
| Inspect html for hidden footers to help with email filtering. To unsubscribe visit settings. |
return false;I believe this will change when the base CL changes. It' undesirable that we do one thing here and another at l.448
voice_isolation_handlerMaybe it would be more readable and consistent if we always pass it but the constructor ignores it if voice_isolation_handler is present?
voice_isolation_handlerMaybe it would be more readable and consistent if we always pass it but the constructor ignores it if voice_isolation_handler is present?
You mean passing the empty unique_ptr in deliver_process_audio_callback, right?
| Inspect html for hidden footers to help with email filtering. To unsubscribe visit settings. |
voice_isolation_handlerPablo Barrera GonzálezMaybe it would be more readable and consistent if we always pass it but the constructor ignores it if voice_isolation_handler is present?
You mean passing the empty unique_ptr in deliver_process_audio_callback, right?
I don't understand. I mean always passing deliver_processed_audio_callback, and then discarding it in the constructor if voice_isolation_handler is no null.
| Inspect html for hidden footers to help with email filtering. To unsubscribe visit settings. |
Extracting VoiceIsolationHandler out of AudioProcessorHandler
The creation of VoiceIsolation should be handled in one place only. This change
consolidates the creation in the InputController as a previous step to move
everything inside VoiceIsolationHandler.
Could you rephrase? I'm not sure I understand what is being said. (VoiceIsolation is created in one place)
Done
I believe this will change when the base CL changes. It' undesirable that we do one thing here and another at l.448
This is now part of MaybeCreateVoiceIsolationHandler.
This is a refactor to move VoiceIsolation and VoiceIsolationHandler creation to the same place. In the follow up I will move VoiceIsolation creationg and model look up inside VoiceIsolationHandler so everything is handled in one place.
Pablo Barrera GonzálezMaybe it would be more readable and consistent if we always pass it but the constructor ignores it if voice_isolation_handler is present?
Olga SharonovaYou mean passing the empty unique_ptr in deliver_process_audio_callback, right?
I don't understand. I mean always passing deliver_processed_audio_callback, and then discarding it in the constructor if voice_isolation_handler is no null.
I am now passing deliver_processed_audio_callback without weird tricks. Internally deliver_processed_audio_callback is used correctly checkig if voice_isolation_handler is valid before accessing it. I added a comment explaining this and I think it's better now.
| Inspect html for hidden footers to help with email filtering. To unsubscribe visit settings. |