86.0.4229.0 fail build in GN gen stage

24 views
Skip to first unread message

sL1pKn07 SpinFlo

unread,
Aug 20, 2020, 1:20:02 PM8/20/20
to chromium-...@chromium.org
ERROR at //v8/gni/v8.gni:199:3: Dependency not allowed.
source_set(target_name) {
^------------------------
The item //v8/src/inspector:inspector_test_headers
can not depend on //v8:features
because it is not in //v8:features's visibility list: [
//v8:*
]

Lei Zhang

unread,
Aug 20, 2020, 1:23:58 PM8/20/20
to sL1pKn07 SpinFlo, chromium-packagers
Do newer 86.x releases build? e.g. Try 86.0.4239.0.
> --
> You received this message because you are subscribed to the Google Groups "chromium-packagers" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to chromium-packag...@chromium.org.
> To view this discussion on the web visit https://groups.google.com/a/chromium.org/d/msgid/chromium-packagers/CAAaYXTs0SZtQO6gcUysmP%2BOJsxY_zkUzsjsgAe3rAJO8n83HLQ%40mail.gmail.com.

sL1pKn07 SpinFlo

unread,
Aug 20, 2020, 1:26:01 PM8/20/20
to Lei Zhang, chromium-packagers
Hi

is a Dev channel release?

Lei Zhang

unread,
Aug 20, 2020, 1:30:16 PM8/20/20
to sL1pKn07 SpinFlo, chromium-packagers
86.0.4239.0 is the current Canary. I'm wondering if it is just an
intermittent breakage with 86.0.4229.0 or not. 86.0.4229.0 is the
current Dev channel release, but shouldn't be for much longer.
> To view this discussion on the web visit https://groups.google.com/a/chromium.org/d/msgid/chromium-packagers/CAAaYXTunXkoHiybsnRDHj%3DZtXzPWnJLeobk8HN6NX1uYiB6gfw%40mail.gmail.com.

sL1pKn07 SpinFlo

unread,
Aug 20, 2020, 1:48:44 PM8/20/20
to Lei Zhang, chromium-packagers
Hi

with 86.0.4239.0

ERROR at //third_party/blink/renderer/platform/heap/BUILD.gn:22:1:
Dependency not allowed.
source_set("heap_unsanitized") {
^-------------------------------
The item //third_party/blink/renderer/platform/heap:heap_unsanitized
can not depend on
//third_party/blink/renderer/platform:blink_platform_implementation
because it is not in
//third_party/blink/renderer/platform:blink_platform_implementation's
visibility list: [
//third_party/blink/renderer/platform:*
//third_party/blink/renderer/platform/heap:test_support
]

greetings

Lei Zhang

unread,
Aug 20, 2020, 2:04:23 PM8/20/20
to sL1pKn07 SpinFlo, chromium-packagers
What version of GN are you using? It's 1819 (e327ffdc) here. The
actual binary is buildtools/linux64/gn in my source tree. Most
recently updated by crrev.com/795954.
> To view this discussion on the web visit https://groups.google.com/a/chromium.org/d/msgid/chromium-packagers/CAAaYXTvpaYrfT9YBtaKwGpDkTX969FmrdZSRd1PKL2-enO9RbA%40mail.gmail.com.

Dirk Pranke

unread,
Aug 20, 2020, 3:08:19 PM8/20/20
to sL1pKn07 SpinFlo, chromium-packagers, Lei Zhang
If you're building GN from scratch, you are likely picking up https://gn.googlesource.com/gn/+/6f13aaac55a977e1948910942675c69f2b4f7a94 which will break builds of v8 and chromium until they've been updated. 

I've filed https://crbug.com/1119933 for this and am currently working on it in https://crrev.com/c/2360685.

That should fix all the issues and roll in the new version, but until that point you should be using a version of GN consistent with what we're using.

-- Dirk

Reply all
Reply to author
Forward
0 new messages