Jae Hoon Kim has uploaded this change for review.
dlcservice: Persist validity stamp for DLCs
We need to persist the validity stamp for DLCs so in the future
dlcservice may respond to Update Engine with valid DLCs instead of the
only returning the currently installed and mounted DLCs.
BUG=chromium:1059126
TEST=FEATURES=test emerge-$B dlcservice dlcservice-client
Change-Id: I8e773dc7e1682cbe4bc643d72ae1481718701234
---
M dlcservice/boot/boot_slot.cc
M dlcservice/boot/boot_slot.h
M dlcservice/dlc.cc
M dlcservice/dlc.h
M dlcservice/dlc_service_test.cc
M dlcservice/utils.cc
M dlcservice/utils.h
7 files changed, 71 insertions(+), 2 deletions(-)
To view, visit change 2141191. To unsubscribe, or for help writing mail filters, visit settings.
Persist Validity Stamp, PTAL~
Patch set 1:Verified +1
7 comments:
remove
File dlcservice/boot/boot_slot.h:
Patch Set #1, Line 37: SlotToStr
this can be named toString since it's obvious what we are converting
has
Patch Set #1, Line 316: BootSlot::SlotToStr(SystemState::Get()->active_boot_slot()),
Are you going to have different subdirs for each slot? this might not be compatible with the prefs class
Patch Set #1, Line 322: :DeleteFile
if you are having multiple directories, it implies that you will store other settings in those directories. In that case, you shouldn't delete the entire directory, just the kDlcValidityFileName file
Patch Set #1, Line 375: PersistValidity();
if it was already mounted, the file should already be there
File dlcservice/dlc_service_test.cc:
change to base::FilePath, it makes it easier to read
To view, visit change 2141191. To unsubscribe, or for help writing mail filters, visit settings.
6 comments:
remove
Patch Set #1, Line 37: SlotToStr
this can be named toString since it's obvious what we are converting
has
Patch Set #1, Line 316: BootSlot::SlotToStr(SystemState::Get()->active_boot_slot()),
Are you going to have different subdirs for each slot? this might not be compatible with the prefs c […]
What prefs class for dlcservice?
Patch Set #1, Line 322: :DeleteFile
if you are having multiple directories, it implies that you will store other settings in those direc […]
Only file in the slot, but doesn't hurt to scope to file. Ack
File dlcservice/dlc_service_test.cc:
change to base::FilePath, it makes it easier to read
Sticking with auto as that's how it's been done and readability is fine.
To view, visit change 2141191. To unsubscribe, or for help writing mail filters, visit settings.