Lenovo N22 REKS recovering with dev image

445 views
Skip to first unread message

Zsolt Furrier

unread,
Mar 17, 2023, 6:05:16 PM3/17/23
to ChromiumOS Development
Good day everyone...!
I'm sure I'll find a helpful person here...
I got access to a Lenovo N22-20 80SF Chrombook that someone flashed Windows 11 on, which required MrChromebox firmware...
I searched the internet to see if I could restore it to its original state, and this is what I found:
https://www.howtogeek.com/279308/how-to-restore-your-chromebooks-original-bios-and-software/

Based on this, based on the description, I set about the restoration...
After I restored the firmware, which the script decoded from the recovery image downloaded from the Internet, since I did not have the original, and the machine copied chromeos and restarted, the phenomenon shown in the attached video occurs despite Ctrl+D, and then a after a while it restarts and again and again...
Stuck in this circle...
I would like a helpful person to prepare the modified dev recovery image for me, because unfortunately I am an absolute beginner and do not have the necessary knowledge...
Thank you in advance for your help...!

https://drive.google.com/file/d/1AYYMJtBZ5E6WWH7d56pghlgVq62GtvNV/view?usp=sharing

https://drive.google.com/file/d/1G0OBZN53YkYyYewb63EusOxhaxAK_NWS/view?usp=sharing

https://drive.google.com/file/d/1Ov0Z2FkkulbUaX_YockZCksDSWB078J8/view?usp=sharing

Zsolt Furrier

unread,
Mar 27, 2023, 11:02:35 AM3/27/23
to ChromiumOS Development, Zsolt Furrier
How to install Chomium OS SDK...?
I would like to do what is described here, if it succeeds...

https://groups.google.com/a/chromium.org/g/chromium-os-dev/c/4xEFP2drimg

Matthew DeVore

unread,
Mar 27, 2023, 5:37:30 PM3/27/23
to Zsolt Furrier, ChromiumOS Development
I am not an expert in device policies, or alternative firmware, so take this with a grain of salt. Hopefully someone more knowledgeable can chime in.

The error in the video says developer mode has been disabled by the "device owner." I would assume you either need to 1) contact the prior owner to revert the policy, 2) use in non-dev mode, or 3) revert to using the alternative firmware. If you purchased the device and it was advertised as a Chromebook perhaps you can return and ask for a refund.

--
--
Chromium OS Developers mailing list: chromiu...@chromium.org
View archives, change email options, or unsubscribe:
https://groups.google.com/a/chromium.org/group/chromium-os-dev
---
To unsubscribe from this group and stop receiving emails from it, send an email to chromium-os-d...@chromium.org.

Zsolt Furrier

unread,
Mar 28, 2023, 4:13:55 PM3/28/23
to ChromiumOS Development, Matthew DeVore, ChromiumOS Development, Zsolt Furrier
1. What was on it with MrChromebox firmware you can't set policies... It works like a normal notebook BIOS...
2. There is no way I can use it... Neither in dev mode nor in non-dev mode...
3. Since I can't use it in any way, so I can't go back to using the alternative firmware either... If you know any trick to solve this, I'd be happy to describe it.. .

The key to solving the problem is...
In the post "Chromebook Kip recovering with dev image" it is described...
Unfortunately, I don't have the knowledge to do that...
I also don't know how to install the Chromium OS SDK required for this operation on Ubuntu...
If I knew this, I would try to create the Reks dev image as described in the post "Chromebook Kip recovering with dev image"...

Jack Rosenthal

unread,
Mar 28, 2023, 8:38:29 PM3/28/23
to Zsolt Furrier, ChromiumOS Development, Matthew DeVore
Since you've already restored the original signed firmware, all you need to do to finish up is put a regular signed ChromeOS recovery image on a USB, and do the regular recovery process (Esc+Refresh+Power, insert recovery USB).

You can find instructions for making a recovery USB here: https://support.google.com/chromebook/answer/1080595 ("Option 2").

When you get this error about recovery mode being disabled by the device owner, the most likely cause is that you simply haven't booted ChromeOS yet and let it do its enterprise enrollment check once you connect to Wi-Fi.  Once this check happens, it'll unset that flag and you're free to enter developer mode.

Zsolt Furrier

unread,
Mar 29, 2023, 3:46:15 PM3/29/23
to ChromiumOS Development, Jack Rosenthal, ChromiumOS Development, Matthew DeVore, Zsolt Furrier
The problem is that the OS won't even boot...
After restoration, this product...

Harry Cutts

unread,
Apr 5, 2023, 12:21:03 PM4/5/23
to ChromiumOS Development, Zsolt Furrier, Jack Rosenthal, ChromiumOS Development, Matthew DeVore
On Wednesday, March 29, 2023 at 8:46:15 PM UTC+1 Zsolt Furrier wrote:
The problem is that the OS won't even boot...

The OS doesn't need to boot for you to be able to use a recovery image. Just give it a try, rather than creating extra threads in the group looking for a different answer.

Luigi Semenzato

unread,
Apr 5, 2023, 1:26:01 PM4/5/23
to ChromiumOS Development, Harry Cutts, Zsolt Furrier, Jack Rosenthal, ChromiumOS Development, Matthew DeVore
Most likely you will not be able to use this chromebook via standard recovery procedures.  Even if you recover it with a recovery image, it will likely keep denying developer mode, and in normal mode it will force re-enrollment, which requires you to have an account with the company or school that used to own it.

It is likely that at this point you will find out who the original owner was, and you may be able to ask them to unenroll the device, if it was legally acquired.

You can, of course, open the case and reflash new firmware on the EEPROM.  There are plenty of instructions on the internet, for instance:

https://www.reddit.com/r/GalliumOS/comments/97ecvv/how_to_recover_a_bricked_via_mrchromebox_firmware/

You will need a Linux computer and an EEPROM programmer.  Note that I do not endorse any of this.

Zsolt Furrier

unread,
Apr 5, 2023, 3:30:17 PM4/5/23
to ChromiumOS Development, Harry Cutts
I'm long past using the recovery image... I've tried recovery many times...
The problem is in the first post...!!!

Zsolt Furrier

unread,
Apr 5, 2023, 3:42:52 PM4/5/23
to ChromiumOS Development, Luigi Semenzato
The problem is described in the first post...
I don't want to put MrChromebox firmware on it, I downloaded it and tried to reset it...
The previous owner was running Win11 with MrChromebox firmware...
I live in Hungary, here schools and companies do not use it... Here Microsoft dominates in all fields, as they support almost everything in the fields of education and company management at the IT level...
I already discussed the problem with the creator of MrChromebox...
He also said that either a USB programmer or a custom recovery disk image is the solution...
Since I don't own a USB programmer, and I'm not going to buy one for more than what I bought the Chrombook for, that leaves the custom recovery image...
Reply all
Reply to author
Forward
0 new messages