Firebase support for Manifest V3 - Firestore / Storage

244 views
Skip to first unread message

Brayan Aguirre

unread,
Apr 10, 2024, 7:59:51 PMApr 10
to Chromium Extensions
Hi. I currently have an extension in manifest V2 and I am migrating it to manifest V3. Turns out I can't use Firebase firestore and storage because XMLHttpRequest is not supported now. 

We are using Firebase 10.10.0. 

Is there any plan for Firebase to adapt to Chrome manifest V3? This is due to the obligation we have to migrate the extension from Chrome.
image_2024-04-10_161442003.png

Patrick Kettner

unread,
Apr 10, 2024, 8:48:47 PMApr 10
to Brayan Aguirre, Chromium Extensions
Hi Brayan!
Thanks so much for reporting this. I am reaching out to the Firebase Storage team to see what we can do. In the meantime, you should be able to continue to use it with xhr-shim

patrick

--
You received this message because you are subscribed to the Google Groups "Chromium Extensions" group.
To unsubscribe from this group and stop receiving emails from it, send an email to chromium-extens...@chromium.org.
To view this discussion on the web visit https://groups.google.com/a/chromium.org/d/msgid/chromium-extensions/2962991a-a121-4c56-b566-ce1f071860dbn%40chromium.org.

Brayan Aguirre

unread,
Apr 12, 2024, 12:05:00 PMApr 12
to Patrick Kettner, Chromium Extensions
At the moment it is the only way we have been able to continue. Thank you. 

Patrick Kettner

unread,
Apr 21, 2024, 1:34:40 PMApr 21
to Jason Savard, Brayan Aguirre, Chromium Extensions
The official library is acceptable, no worries. 

On Sun, Apr 21, 2024 at 10:54 AM Jason Savard <jason...@gmail.com> wrote:
Hi Patrick, I have successfully integrated the firebase-firestore.js using the offscreen api in my MV3 extension locally, but the only library version I found contains obfuscated code which will probably not pass a Chrome store review.
How or where can I obtain a version that is not obfuscated?
Note that minified is ok.

Jason Savard

unread,
Apr 21, 2024, 2:55:06 PMApr 21
to Chromium Extensions, Brayan Aguirre, Chromium Extensions, Patrick Kettner
Hi Patrick, I have successfully integrated the firebase-firestore.js using the offscreen api in my MV3 extension locally, but the only library version I found contains obfuscated code which will probably not pass a Chrome store review.
How or where can I obtain a version that is not obfuscated?
Note that minified is ok.

On Friday, April 12, 2024 at 12:05:00 p.m. UTC-4 Brayan Aguirre wrote:
Reply all
Reply to author
Forward
0 new messages