Router password cannot be saved?

543 views
Skip to first unread message

Aviad Raviv

unread,
Jul 19, 2010, 4:44:31 AM7/19/10
to Chromium-discuss
Hello all.
I have a Linksys router with DD-WRT on it.
I have noticed that with chromium I don't get prompted to save the
router's web-gui password, not by the browser and not by the lasstpass
extension i installed.
I am using multiple computers, so I have several version of chromium,
the version i am using to perform this post is v52042, but at home i
have an even newer one that I downloaded last night with the same
behavior.

Is this some sort of setting i am missing or a bug?

(I know that DD-WRT uses ASP pages for its web-gui if that's any help)

Thank you in advance, Aviad.

PhistucK

unread,
Jul 19, 2010, 11:53:24 AM7/19/10
to avi...@gmail.com, Chromium-discuss
And other browsers can?
Which can? which cannot?

☆PhistucK



--
Chromium Discussion mailing list: chromium...@chromium.org
View archives, change email options, or unsubscribe:
   http://groups.google.com/a/chromium.org/group/chromium-discuss

PhistucK

unread,
Jul 20, 2010, 12:48:07 AM7/20/10
to Aviad Raviv, Chromium-discuss
Please keep chromium-discuss as CC (or just hit "Replay to all").

Can you try and see if other browsers can currently save your password in these pages?

☆PhistucK


On Tue, Jul 20, 2010 at 07:44, Aviad Raviv <avi...@gmail.com> wrote:
well i'v never had a issue saving the password... using IE6 ~ 8, Firefox and chrome.
its just now with chromium that i noticed its not even giving me the option.

Aviad Raviv

unread,
Jul 20, 2010, 1:16:44 AM7/20/10
to PhistucK, Chromium-discuss
sure thanks for the "reply to all" hint.
chrome 5.0.375.99 - already saved, so i'm guessing it worked at least once...
Firefox 3.6.4 - offered to save (over bar popup)
IE 8.0.7600.16385 - offered to save (popup windows with "remember" checkbox)

The chromium version i have now tested with is 52858 and i have confirmed that "Offer to save passwords" is checked.

Please let me know what more information i can provide, including access to the router if need be.
Thanks.

PhistucK

unread,
Jul 20, 2010, 1:29:35 AM7/20/10
to Aviad Raviv, Chromium-discuss
If you could download some Chromium builds (say, one every 1000 builds or so) and see which one of them does offer to save that password, that will help a lot (since we cannot really access that page) and will determine when it has regressed.
Once you find a build in which it works and a closer build in which it does not work, post your results here and, if possible, the login page.

☆PhistucK

Aviad Raviv

unread,
Jul 20, 2010, 1:36:16 AM7/20/10
to PhistucK, Chromium-discuss
will do, but later on today.

Aviad Raviv

unread,
Jul 20, 2010, 3:01:34 AM7/20/10
to PhistucK, Chromium-discuss
I am sorry to report that i failed on my first go??
As in I uninstalled the current installed version, downloaded and installed v51003 and tried to access the router... again I was not prompted to save the password :\
Just in case i, again, confirmed that the "Offer to save passwords" radio option is selected.

Should i try on a fresh machine that doesn't have my browsing data from the new version?
BTW using win7 on all my machines.

Please advise...

Aviad Raviv

unread,
Jul 20, 2010, 3:36:48 AM7/20/10
to PhistucK, Chromium-discuss
update:
Just tried on a win7 machine that has *never* had chromium installed on it.
Installed build v51003, and got the same behavior.

Is there an earlier build i can try?

PhistucK

unread,
Jul 20, 2010, 4:26:42 AM7/20/10
to Aviad Raviv, Chromium-discuss
Sorry, I assumed there were earlier builds there.
This one has earlier builds -

☆PhistucK

Aviad Raviv

unread,
Jul 20, 2010, 5:07:19 AM7/20/10
to PhistucK, Chromium-discuss
OK... just found in what version this functionality worked last.
on version 47499 i am offered to save the password with an over-bar after being prompted with a popup dialog box (similar to Firefox).
on version 47633 this no longer happens.

I'll arrange a router that you can log into remotely this evening for testings.
BTW the regression tests were performed on an XP machine.



On Tue, Jul 20, 2010 at 11:32 AM, Aviad Raviv <avi...@gmail.com> wrote:
getting on it...
thanks

PhistucK

unread,
Jul 22, 2010, 1:25:43 AM7/22/10
to Aviad Raviv, Chromium-discuss
You can close your public web user interface now (I went abroad yesterday, so it took me some time to answer, sorry).
You can file a new issue at new.crbug.com.
Please, make sure you specify the information regarding the last build in which it works and add this test page -

Thank you!

☆PhistucK


On Wed, Jul 21, 2010 at 23:58, Aviad Raviv <avi...@gmail.com> wrote:
Sorry for the delay, but ya know... life...  
 (This part was removed from the message, due to security concerns.)

Thank you, and please let me know how can i bee of further assistance, Aviad.
Reply all
Reply to author
Forward
0 new messages