Failed cronet build

Skip to first unread message

Goodsol Lee

Sep 4, 2021, 8:33:22 AM9/4/21
to Chromium-discuss
Hi, I'm newbee who wanna adopt cronet on my research.

I face the problem while building cronet with command: ninja -C out/Debug cronet_package in I followed all instructions before facing the error. 

The error log says there is no jar file, but I can't know what is jar file and where is it. The error log is as follows:

root@35f93f51d733:/home/mobisys22/quic/chromium/src# ninja -C out/Debug cronet_package
ninja: Entering directory `out/Debug'
[31/1893] ACTION //components/cronet/android:generate_javadoc(//build/toolchain/android:android_clang_arm)
FAILED: gen/components/cronet/android/ 
python3 ../../components/cronet/tools/ --output-dir cronet --input-dir ../../components/cronet --overview-file cronet/ --readme-file ../../components/cronet/ --depfile gen/components/cronet/android/generate_javadoc.d --zip-file gen/components/cronet/android/ --android-sdk-jar ../../third_party/android_sdk/public/platforms/android-31/android.jar --support-annotations-jar --input-src-jar cronet/cronet_api-src.jar
Traceback (most recent call last):
  File "../../components/cronet/tools/", line 141, in <module>
  File "../../components/cronet/tools/", line 116, in main
    build_utils.CheckOutput(jar_cmd, cwd=unzipped_jar_path)
  File "/home/mobisys22/quic/chromium/src/build/android/gyp/util/", line 259, in CheckOutput
    stdout=subprocess.PIPE, stderr=subprocess.PIPE, cwd=cwd, env=env)
  File "/usr/lib/python3.6/", line 729, in __init__
    restore_signals, start_new_session)
  File "/usr/lib/python3.6/", line 1364, in _execute_child
    raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: 'jar': 'jar'
[52/1893] ACTION //components/cronet/android:cronet_test_apk_java__errorprone(//build/toolchain/android:android_clang_arm)
ninja: build stopped: subcommand failed.

Thanks in advance.

Goodsol Lee

Sep 5, 2021, 2:32:46 AM9/5/21
to Chromium-discuss, Goodsol Lee
Hi, I solved the problem with very simple shell command.

With installation of open jdk, problem can be solved.

shell command:  sudo apt-get install openjdk-8-jdk

Hope this may help someone.

2021년 9월 4일 토요일 오후 9시 33분 22초 UTC+9에 Goodsol Lee님이 작성:
Reply all
Reply to author
0 new messages