Error in giving 'gclient' command on cmd while building chromium

Skip to first unread message

Avi Mathur

Feb 7, 2023, 12:12:03 PMFeb 7
to Chromium-dev
Hi everyone, 
I have been following all the steps related to building chromium and getting the source code, from the chromium documentation, as given here:
But I am facing an issue while running the command 'gclient' on cmd (also on git bash/powershell), with the current directory as the one of 'depot_tools'. My path to 'depot_tools' is the same as the one specified in the documentation, and I had extracted the file, by NOT drag and drop, but proper exraction directly at the required location. 
Specifically about the issue. When I run the 'gclient' command on cmd, I get the error, saying:
using C:\Users\AVIMAT~1\AppData\Local\Temp\goma as tmpdir
compiler_proxy is not running

I had tried looking the error solution on 'chromium bugs' but I was not able to find any solution for it. I am also attaching a screen shot showing the same issue on cmd. 
May somebody please help me to resolve the issue! 

Thanks in Advance 


K. Moon

Feb 7, 2023, 12:28:46 PMFeb 7
to, Chromium-dev
There's no actual error here, you're just getting the gclient usage message because you haven't provided a subcommand like "sync".

The message is coming from the Goma update hook, which is just irrelevant noise. (It is a bit annoying that the update hook isn't quieter.)

Chromium Developers mailing list:
View archives, change email options, or unsubscribe:
You received this message because you are subscribed to the Google Groups "Chromium-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
To view this discussion on the web visit

Avi Mathur

Feb 7, 2023, 4:50:24 PMFeb 7
to Chromium-dev,, Chromium-dev, Avi Mathur
Oh okay, yeah got it. 
Thanks a lot for the clarification! I have been stuck on it for sometime now. 
Reply all
Reply to author
0 new messages