About Gamepad multitouch

62 views
Skip to first unread message

于洋

unread,
Jun 13, 2024, 10:49:51 AMJun 13
to Chromium-dev, mattre...@chromium.org, bradley...@sony.com
Hello~
I saw chromium has supported Gamepad multitouch API in this patch:
I tried to check this API with these 2 Samples, but got same results:
I pressed buttons, joysticks and touch the touchpad(is this the correct way to invoke multitouch API?),
Buttons and joysticks works fine in UI but controller.touchEvents always return null,
my device runs with Chromium M120 and arm architecture with linux type OS.

I also tried to run with my PC with Win10 and this chrome version:
版本 125.0.6422.142(正式版本) (64 位)
it has the same result, controller.touchEvents is always null.

Could you share the possible reason of this issue please?
Does the API only support in Windows OS?
there seems no change in linux related code in the patch, 
GamepadDeviceLinux seems not called Dualshock4Controller::ProcessInputReport to update touch events.

Thank you!


Reply all
Reply to author
Forward
0 new messages