Force Legacy Video Accelerator (VDA) For Video Decoding

103 views
Skip to first unread message

Ali Saleh

unread,
Sep 28, 2021, 5:11:46 PM9/28/21
to Chromium-dev
Hi,
I'm using Chromium 94 on Linux and the new 'VideoDecoder' doesn't work for me. It shows up as 'Unknown Video Decoder' in media-internals and falls back to software decoding, whereas the legacy video accelerator (VDA) used to work well with no issues like this.
2021-09-27_12-07.png
2021-09-27_09-37.png
It should try the legacy one if the new one fails but instead uses vpx decoder.
I'd like to force the legacy video accelerator but I can't find any switch or flag to do this.

Thanks for your help in advance.

Ali Saleh

unread,
Oct 4, 2021, 12:53:19 PM10/4/21
to Chromium-dev, Ali Saleh
I killed the 'GPU Process' manually and the new VideoDecoder disappeared. Now VDA works! I don't have any idea why this happens but it's better than nothing.

I hope chromium devs gave us an option to choose the video decoder (I think there is one for chrome os but not for other os's)

Thanassis M.

unread,
Oct 8, 2021, 7:07:12 PM10/8/21
to Chromium-dev, alire...@gmail.com
Exactly the same problem on Skylake with i965 driver - Linux Chromium 94.

Tried --enable-features=,ForceHardwareVideoDecoders after new decoder failure hoping that will pickup the legacy, but didn't work.

Is the chromeos flag --platform-disallows-chromeos-direct-video-decoder relevant?

Ali Saleh

unread,
Oct 11, 2021, 7:40:37 PM10/11/21
to Chromium-dev, misa...@gmail.com, Ali Saleh
After a few days the problem magically went away for me. Now I don't even need to kill the 'GPU Process'.

I tried many different flags and switches before but none of them seemed to be relevant.
My chromium is version 94.0.4606.71

Reply all
Reply to author
Forward
0 new messages