I wanted to revisit @NO_DUMP/@NO_CHILDREN_DUMP instructions which are used to filter nodes out from the result tree in ax dump tree testing. @NO_DUMP is an in-test-case instruction unlike other instructions which was introduced in  to keep the expectation file smaller and thus more readable. DumpTree tests also have a similar @DENY-NODE instruction to filter out the result tree.
* @NO_DUMP are in-test instructions which makes them sort out of box of the overall concept which is instructions are separate from the test
* @NO_DUMP instructions are currently implemented for ax dump tree tests only, so they cannot be used in ax_dump_tree tool
* @NO_DUMP instructions capabilities are partially duplicated by @DENY-NODE instruction.
Would it make sense to merge @NO_DUMP and @DENY-NODE? I'd say @DENY-NODE can be extended to indicate DOM ids (which are exposed via accessibility APIs and thus can be used outside Chromium internal testing). DOM ids would allow easily to indicate which accessible to filter out. Plus a new @DENY-CHILDREN would replace @NO_CHILDREN_DUMP.