Tidy up loops and rename function in HTMLPictureElement [chromium/src : main]

0 views
Skip to first unread message

Fredrik Söderquist (Gerrit)

unread,
Mar 20, 2023, 12:33:27 PM3/20/23
to Dominic Farolino, blink-rev...@chromium.org, blink-...@chromium.org

Attention is currently required from: Dominic Farolino.

Fredrik Söderquist would like Dominic Farolino to review this change.

View Change

Tidy up loops and rename function in HTMLPictureElement

* Transform some loops to use range-for and Traversal<>::ChildrenOf().

* Rename SourceAttributeChanged() to SourceDimensionChanged() to better
reflect its - fairly specific - task.

Bug: 1233739
Change-Id: I004ab4155a11ced49ed9b4d85b6dbb395c0157af
---
M third_party/blink/renderer/core/html/html_picture_element.cc
M third_party/blink/renderer/core/html/html_picture_element.h
M third_party/blink/renderer/core/html/html_source_element.cc
3 files changed, 15 insertions(+), 25 deletions(-)


To view, visit change 4352656. To unsubscribe, or for help writing mail filters, visit settings.

Gerrit-Project: chromium/src
Gerrit-Branch: main
Gerrit-Change-Id: I004ab4155a11ced49ed9b4d85b6dbb395c0157af
Gerrit-Change-Number: 4352656
Gerrit-PatchSet: 1
Gerrit-Owner: Fredrik Söderquist <f...@opera.com>
Gerrit-Reviewer: Dominic Farolino <d...@chromium.org>
Gerrit-Reviewer: Fredrik Söderquist <f...@opera.com>
Gerrit-Attention: Dominic Farolino <d...@chromium.org>
Gerrit-MessageType: newchange

Fredrik Söderquist (Gerrit)

unread,
Mar 20, 2023, 12:33:29 PM3/20/23
to blink-rev...@chromium.org, blink-...@chromium.org, Dominic Farolino, Chromium LUCI CQ, chromium...@chromium.org

Attention is currently required from: Dominic Farolino.

Patch set 1:Auto-Submit +1

View Change

    To view, visit change 4352656. To unsubscribe, or for help writing mail filters, visit settings.

    Gerrit-Project: chromium/src
    Gerrit-Branch: main
    Gerrit-Change-Id: I004ab4155a11ced49ed9b4d85b6dbb395c0157af
    Gerrit-Change-Number: 4352656
    Gerrit-PatchSet: 1
    Gerrit-Owner: Fredrik Söderquist <f...@opera.com>
    Gerrit-Reviewer: Dominic Farolino <d...@chromium.org>
    Gerrit-Reviewer: Fredrik Söderquist <f...@opera.com>
    Gerrit-Attention: Dominic Farolino <d...@chromium.org>
    Gerrit-Comment-Date: Mon, 20 Mar 2023 16:33:24 +0000
    Gerrit-HasComments: No
    Gerrit-Has-Labels: Yes
    Gerrit-MessageType: comment

    Dominic Farolino (Gerrit)

    unread,
    Mar 21, 2023, 12:05:16 AM3/21/23
    to Fredrik Söderquist, blink-rev...@chromium.org, blink-...@chromium.org, Chromium LUCI CQ, chromium...@chromium.org

    Attention is currently required from: Fredrik Söderquist.

    Patch set 1:Code-Review +1Commit-Queue +2

    View Change

      To view, visit change 4352656. To unsubscribe, or for help writing mail filters, visit settings.

      Gerrit-Project: chromium/src
      Gerrit-Branch: main
      Gerrit-Change-Id: I004ab4155a11ced49ed9b4d85b6dbb395c0157af
      Gerrit-Change-Number: 4352656
      Gerrit-PatchSet: 1
      Gerrit-Owner: Fredrik Söderquist <f...@opera.com>
      Gerrit-Reviewer: Dominic Farolino <d...@chromium.org>
      Gerrit-Reviewer: Fredrik Söderquist <f...@opera.com>
      Gerrit-Attention: Fredrik Söderquist <f...@opera.com>
      Gerrit-Comment-Date: Tue, 21 Mar 2023 04:05:09 +0000

      Chromium LUCI CQ (Gerrit)

      unread,
      Mar 21, 2023, 12:15:09 AM3/21/23
      to Fredrik Söderquist, blink-rev...@chromium.org, blink-...@chromium.org, Dominic Farolino, chromium...@chromium.org

      Chromium LUCI CQ submitted this change.

      View Change

      Approvals: Dominic Farolino: Looks good to me; Commit Fredrik Söderquist: Send CL to CQ automatically after approval
      Tidy up loops and rename function in HTMLPictureElement

      * Transform some loops to use range-for and Traversal<>::ChildrenOf().

      * Rename SourceAttributeChanged() to SourceDimensionChanged() to better
      reflect its - fairly specific - task.

      Bug: 1233739
      Change-Id: I004ab4155a11ced49ed9b4d85b6dbb395c0157af
      Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/4352656
      Reviewed-by: Dominic Farolino <d...@chromium.org>
      Commit-Queue: Dominic Farolino <d...@chromium.org>
      Auto-Submit: Fredrik Söderquist <f...@opera.com>
      Cr-Commit-Position: refs/heads/main@{#1119768}

      ---
      M third_party/blink/renderer/core/html/html_picture_element.cc
      M third_party/blink/renderer/core/html/html_picture_element.h
      M third_party/blink/renderer/core/html/html_source_element.cc
      3 files changed, 15 insertions(+), 25 deletions(-)


      To view, visit change 4352656. To unsubscribe, or for help writing mail filters, visit settings.

      Gerrit-Project: chromium/src
      Gerrit-Branch: main
      Gerrit-Change-Id: I004ab4155a11ced49ed9b4d85b6dbb395c0157af
      Gerrit-Change-Number: 4352656
      Gerrit-PatchSet: 2
      Gerrit-Owner: Fredrik Söderquist <f...@opera.com>
      Gerrit-Reviewer: Chromium LUCI CQ <chromiu...@luci-project-accounts.iam.gserviceaccount.com>
      Gerrit-Reviewer: Dominic Farolino <d...@chromium.org>
      Gerrit-Reviewer: Fredrik Söderquist <f...@opera.com>
      Gerrit-MessageType: merged
      Reply all
      Reply to author
      Forward
      0 new messages