Blank Text in PDF/Print from WebView (v102.0.5005.78)

70 views
Skip to first unread message

Maunik Shah

unread,
Jun 6, 2022, 2:50:29 PMJun 6
to android-webview-dev
Hello Devs,

With the recent update of "Android System WebView" (v102.0.5005.78) on Playstore, printing or making PDF from WebView is impacted and partial broken on some devices like OnePlus 6T, Samsung s6 edge, Note 10 lite, Oppo F21 pro etc. 

When we try to print on A4 printer or make PDF file from Webview of our Android app, it's making all normal character blank and shows only bold characters as an output starting from the above mentioned webview version.

Our app users started complaining about the issue and we are right now suggesting them to uninstall the Android System Webview to fall back to some previous version so that, they can work with our business app.

Could anyone please check on this issue (PFA video) and let us know whether it is being internally 
tracked?

Image for non-working case                           Image for working case
(v102.0.5005.78)                                               (some previous version)
WebView-non-working.jpeg      WebView-working.jpeg  


Thank you,
Maunik Shah
WebView_Issue.mp4

Torne (Richard Coles)

unread,
Jun 6, 2022, 5:12:31 PMJun 6
to Maunik Shah, android-webview-dev
Please file a webview bug with instructions on how to reproduce the issue and any other information you have, and we can investigate: https://bugs.chromium.org/p/chromium/issues/entry?template=Webview+Bugs

--
You received this message because you are subscribed to the Google Groups "android-webview-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-webview...@chromium.org.
To view this discussion on the web visit https://groups.google.com/a/chromium.org/d/msgid/android-webview-dev/2902e755-a5b2-4a3a-bd37-ab741d0adb2fn%40chromium.org.

Maunik Shah

unread,
Jun 7, 2022, 6:51:11 AMJun 7
to android-webview-dev, to...@chromium.org, android-webview-dev, Maunik Shah
Created bug here

Philipp Nowak

unread,
Jun 8, 2022, 5:38:39 AMJun 8
to android-webview-dev, maun...@gmail.com, to...@chromium.org, android-webview-dev
We are also facing this issue on Pixel 6 Pro and Pixel 5 with WebView version 102.0.5005.78, but on a Pixel 4a with the same version the issue is not happening.

Simon Bergeron

unread,
Jun 13, 2022, 12:28:30 PMJun 13
to android-webview-dev, Philipp Nowak, maun...@gmail.com, to...@chromium.org, android-webview-dev
I'm seeing this same issue on the most recent Samsung Galaxy phones (S10 - S22). 
Broke last week when devices updated the Android System Webview to version 102.0.5005.78.
Reply all
Reply to author
Forward
0 new messages