Missing language defines

Showing 1-12 of 12 messages
Missing language defines Jamie Reid 1/10/13 5:36 AM
Hi all,

I am new to chromium and am trying to build it for the first time. I am on Windows 8 and using VS2010.

I have tried to build with Visual Studio and get a series of errors regarding the a missing file realted to nacl. If I disable nacl via chromium.gyp_env and the GY_DEFINES, that error disappears. Then another error is generated regarding missing definitions.

I have now moved to building with ninja. It seems the nacl issue isn't present here. However, i still get the missing defines issue in ninja. As installer_util_strings.h is an auto generated file I am wondering if I am doing something wrong in the settings.
Below is the error ninja produces:

[1091/18952] LINK(DLL) icuuc.dll
icuuc.udata.obj : warning LNK4049: locally defined symbol _icudt46_dat imported
[2240/18952] CXX obj\chrome\installer\..._util_nacl_win64.language_selector.obj
FAILED: ninja -t msvc -o obj\chrome\installer\util\installer_util_nacl_win64.lan
guage_selector.obj -e environment.x64 -- cl.exe /nologo /showIncludes /FC @obj\c
hrome\installer\util\installer_util_nacl_win64.language_selector.obj.rsp  /c ..\
..\chrome\installer\util\language_selector.cc /Foobj\chrome\installer\util\insta
ller_util_nacl_win64.language_selector.obj  /Fdinstaller_util_nacl_win64.pdb
g:\[05]kidscontent\chromium\src\chrome\installer\util\language_selector.cc(47) :
 error C2065: 'IDS_L10N_OFFSET_EN_GB' : undeclared identifier
g:\[05]kidscontent\chromium\src\chrome\installer\util\language_selector.cc(48) :
 error C2065: 'IDS_L10N_OFFSET_EN_GB' : undeclared identifier
g:\[05]kidscontent\chromium\src\chrome\installer\util\language_selector.cc(49) :
 error C2065: 'IDS_L10N_OFFSET_EN_GB' : undeclared identifier
g:\[05]kidscontent\chromium\src\chrome\installer\util\language_selector.cc(50) :
 error C2065: 'IDS_L10N_OFFSET_EN_GB' : undeclared identifier
g:\[05]kidscontent\chromium\src\chrome\installer\util\language_selector.cc(52) :
 error C2065: 'IDS_L10N_OFFSET_ES' : undeclared identifier
g:\[05]kidscontent\chromium\src\chrome\installer\util\language_selector.cc(54) :
 error C2065: 'IDS_L10N_OFFSET_IW' : undeclared identifier
g:\[05]kidscontent\chromium\src\chrome\installer\util\language_selector.cc(56) :
 error C2065: 'IDS_L10N_OFFSET_NO' : undeclared identifier
g:\[05]kidscontent\chromium\src\chrome\installer\util\language_selector.cc(59) :
 error C2065: 'IDS_L10N_OFFSET_FIL' : undeclared identifier
g:\[05]kidscontent\chromium\src\chrome\installer\util\language_selector.cc(61) :
 error C2065: 'IDS_L10N_OFFSET_ZH_CN' : undeclared identifier
g:\[05]kidscontent\chromium\src\chrome\installer\util\language_selector.cc(62) :
 error C2065: 'IDS_L10N_OFFSET_ZH_TW' : undeclared identifier
g:\[05]kidscontent\chromium\src\chrome\installer\util\language_selector.cc(64) :
 error C2065: 'IDS_L10N_OFFSET_ZH_CN' : undeclared identifier
g:\[05]kidscontent\chromium\src\chrome\installer\util\language_selector.cc(65) :
 error C2065: 'IDS_L10N_OFFSET_ZH_TW' : undeclared identifier
g:\[05]kidscontent\chromium\src\chrome\installer\util\language_selector.cc(67) :
 error C2065: 'IDS_L10N_OFFSET_ZH_TW' : undeclared identifier
g:\[05]kidscontent\chromium\src\chrome\installer\util\language_selector.cc(68) :
 error C2065: 'IDS_L10N_OFFSET_ZH_TW' : undeclared identifier
g:\[05]kidscontent\chromium\src\chrome\installer\util\language_selector.cc(71) :
 error C2065: 'IDS_L10N_OFFSET_ZH_CN' : undeclared identifier
g:\[05]kidscontent\chromium\src\chrome\installer\util\language_selector.cc(80) :
 error C2065: 'IDS_L10N_OFFSET_ES_419' : undeclared identifier
g:\[05]kidscontent\chromium\src\chrome\installer\util\language_selector.cc(82) :
 error C2065: 'IDS_L10N_OFFSET_PT_BR' : undeclared identifier
g:\[05]kidscontent\chromium\src\chrome\installer\util\language_selector.cc(84) :
 error C2065: 'IDS_L10N_OFFSET_ZH_CN' : undeclared identifier
[2240/18952] CXX obj\chrome\installer\...aller_util_nacl_win64.install_util.obj
ninja: build stopped: subcommand failed.
unk...@googlegroups.com 1/10/13 7:15 AM <This message has been deleted.>
Re: [chromium-dev] Missing language defines Jamie Reid 1/10/13 7:54 AM
Hi Gabriel,

The file contains the following:
{'GYP_DEFINES': 'component=shared_library'} # use space to delimit additional defines.

I have not modified the PC's environment variables and have not modified them via SET on the command prompt.

Is there some specific environment variable to enforce it to build certain languages (or all languages)

Many thanks in advance


Kind regards,

Jamie Reid

On 10/01/2013 15:25, Gabriel Charette wrote:

What is in your chromium.gyp_env exactly?

Do you have any other environment variables affecting your build?

Le 10 janv. 2013 08:36, "Jamie Reid" <jamie....@gmail.com> a écrit :
--
Chromium Developers mailing list: chromi...@chromium.org
View archives, change email options, or unsubscribe:
http://groups.google.com/a/chromium.org/group/chromium-dev

Re: [chromium-dev] Missing language defines Scott Graham 1/10/13 8:08 AM
Is "g:\[05]kidscontent" the actual path? I would suspect that there's some tool that doesn't like [/] in path names.

--
Chromium Developers mailing list: chromi...@chromium.org
View archives, change email options, or unsubscribe:
http://groups.google.com/a/chromium.org/group/chromium-dev

Re: [chromium-dev] Missing language defines Jamie Reid 1/10/13 8:12 AM
It is the actual path? Can I just copy the folder to G:\ and then run the sync/runhooks again or do I need to start from scratch?
Re: [chromium-dev] Missing language defines Scott Graham 1/10/13 8:12 AM
I think moving it should be fine.
Re: [chromium-dev] Missing language defines Jamie Reid 1/10/13 8:32 AM
turns out moving will take a while so I'll start from scratch probably quicker
Re: [chromium-dev] Missing language defines Jamie Reid 1/10/13 11:26 AM
I now have a new error, going to try with Visual Studio now also to see if the directory change helps VS.

ninja error is below and is much further along in the process:

G:\chromium\src>ninja -C out\Debug chrome.exe
ninja: Entering directory `out\Debug'
[1109/13215] LINK(DLL) icuuc.dll

icuuc.udata.obj : warning LNK4049: locally defined symbol _icudt46_dat imported
[1704/13215] RULE Assembling nacl_swit...x86_64.gen\nacl_switch_unwind_win.obj.
 Assembling: nacl_switch_unwind_win.asm
Microsoft (R) Macro Assembler (x64) Version 10.00.30319.01
Copyright (C) Microsoft Corporation.  All rights reserved.
      1 [main] clang 8876 child_info_fork::abort: G:\chromium\src\out\Debug\gen\
sdk\toolchain\win_x86_pnacl\host_x86_32\bin\cygLLVM-3.3svn.dll: Loaded to differ
ent address: parent(0x1D10000) != child(0x68140000)
      0 [main] clang 11052 child_info_fork::abort: G:\chromium\src\out\Debug\gen
\sdk\toolchain\win_x86_pnacl\host_x86_32\bin\cygLLVM-3.3svn.dll: Loaded to diffe
rent address: parent(0x1D10000) != child(0x68140000)
[4756/13215] ACTION platform_lib: buil... plib_409da68b060d10246c29d1d618a15d20
FAILED: G:\[05]Kidscontent\depot_tools\python_bin\python.exe gyp-win-tool action
-wrapper environment.x86 platform_lib_target_build_newlib_plib_409da68b060d10246
c29d1d618a15d20..rsp ..\..\native_client\src\shared\platform
      1 [main] clang 8876 child_info_fork::abort: G:\chromium\src\out\Debug\gen\
sdk\toolchain\win_x86_pnacl\host_x86_32\bin\cygLLVM-3.3svn.dll: Loaded to differ
ent address: parent(0x1D10000) != child(0x68140000)
clang: error: unable to execute command: Couldn't fork: Resource temporarily una
vailable
clang: error: clang frontend command failed due to signal (use -v to see invocat
ion)
clang version 3.3 (http://llvm.org/git//clang.git 2e39713a3d72c243a2bcd13cc8f503
6ba6b487d9) (http://git.chromium.org/native_client/pnacl-llvm.git 34b5ac3285795c
2f867d959279e11d920946a3f8)
Target: le32-unknown-nacl
Thread model: posix
clang: note: diagnostic msg: PLEASE submit a bug report to http://llvm.org/bugs/
 and include the crash backtrace, preprocessed source, and associated run script
.
      0 [main] clang 11052 child_info_fork::abort: G:\chromium\src\out\Debug\gen
\sdk\toolchain\win_x86_pnacl\host_x86_32\bin\cygLLVM-3.3svn.dll: Loaded to diffe
rent address: parent(0x1D10000) != child(0x68140000)
clang: error: unable to execute command: Couldn't fork: Resource temporarily una
vailable
clang: note: diagnostic msg: Error generating preprocessed source(s).

>>>../../../../native_client/build/build_nexe.py>> <<-t>> <<..\..\..\..\out\Debu
g/gen/sdk/toolchain/>> <<--arch>> <<pnacl>> <<--build>> <<newlib_plib>> <<--root
>> <<../../../..>> <<--name>> <<..\..\..\..\out\Debug/gen/tc_pnacl_newlib/lib/li
bplatform.a>> <<--objdir>> <<..\..\..\..\out\Debug\obj\native_client\src\shared\
platform\platform_lib.gen/pnacl_newlib-pnacl/platform_lib>> <<--include-dirs=..\
..\..\..\out\Debug/gen/tc_pnacl_newlib/include ../../../.. ../../../../ppapi ../
../../src/third_party ../../../.. ../../../../third_party/wtl/include>> <<--lib-
dirs= >> <<--compile_flags=-O2 -g -Wall -Werror -fdiagnostics-show-option  -Wno-
unused-function -Wno-char-subscripts -Wno-c++11-extensions -Wno-unnamed-type-tem
plate-args -Wno-extra-semi -Wno-unused-private-field >> <<--defines=__linux__ "_
_STDC_LIMIT_MACROS=1" "__STDC_FORMAT_MACROS=1" "_GNU_SOURCE=1" "_BSD_SOURCE=1" "
_POSIX_C_SOURCE=199506" "_XOPEN_SOURCE=600" "DYNAMIC_ANNOTATIONS_ENABLED=1" "DYN
AMIC_ANNOTATIONS_PREFIX=NACL_" "NACL_BUILD_ARCH=x86" "_WIN32_WINNT=0x0602" "WINV
ER=0x0602" WIN32 _WINDOWS NOMINMAX "PSAPI_VERSION=1" _CRT_RAND_S CERT_CHAIN_PARA
_HAS_EXTRA_FIELDS WIN32_LEAN_AND_MEAN _ATL_NO_OPENGL _SECURE_ATL "_WIN32_WINNT=0
x0600" "WINVER=0x0600" "__STDC_LIMIT_MACROS=1" "NACL_LINUX=0" "NACL_ANDROID=0" "
NACL_OSX=0" "NACL_WINDOWS=1" _CRT_SECURE_NO_DEPRECATE _CRT_NONSTDC_NO_WARNINGS _
CRT_NONSTDC_NO_DEPRECATE _SCL_SECURE_NO_DEPRECATE CHROMIUM_BUILD COMPONENT_BUILD
 "TOOLKIT_VIEWS=1" "USE_LIBJPEG_TURBO=1" ENABLE_ONE_CLICK_SIGNIN "ENABLE_REMOTIN
G=1" "ENABLE_WEBRTC=1" ENABLE_PEPPER_THREADING ENABLE_CONFIGURATION_POLICY ENABL
E_INPUT_SPEECH ENABLE_NOTIFICATIONS NO_TCMALLOC "ENABLE_GPU=1" "ENABLE_EGLIMAGE=
1" "USE_SKIA=1" __STD_C "NTDDI_VERSION=0x06020000" "ENABLE_TASK_MANAGER=1" "ENAB
LE_WEB_INTENTS=1" "ENABLE_EXTENSIONS=1" "ENABLE_PLUGIN_INSTALLATION=1" "ENABLE_P
LUGINS=1" "ENABLE_SESSION_SERVICE=1" "ENABLE_THEMES=1" "ENABLE_BACKGROUND=1" "EN
ABLE_AUTOMATION=1" "ENABLE_GOOGLE_NOW=1" "ENABLE_LANGUAGE_DETECTION=1" "ENABLE_P
RINTING=1" "ENABLE_CAPTIVE_PORTAL_DETECTION=1" "ENABLE_APP_LIST=1" "ENABLE_MESSA
GE_CENTER=1" "ENABLE_SETTINGS_APP=1" "NACL_TARGET_SUBARCH=32" "NACL_TARGET_ARCH=
x86" "NACL_BUILD_SUBARCH=32" "NACL_BUILD_ARCH=x86">> <<--link_flags=-B..\..\..\.
.\out\Debug/gen/tc_pnacl_newlib/lib  >> <<--source-list=pnacl_newlib.platform_li
b.source_list.gypcmd<<
../../../../native_client/build/build_nexe.py -t ..\..\..\..\out\Debug/gen/sdk/t
oolchain/ --arch pnacl --build newlib_plib --root ../../../.. --name ..\..\..\..
\out\Debug/gen/tc_pnacl_newlib/lib/libplatform.a --objdir ..\..\..\..\out\Debug\
obj\native_client\src\shared\platform\platform_lib.gen/pnacl_newlib-pnacl/platfo
rm_lib --include-dirs=..\..\..\..\out\Debug/gen/tc_pnacl_newlib/include ../../..
/.. ../../../../ppapi ../../../src/third_party ../../../.. ../../../../third_par
ty/wtl/include --lib-dirs=  --compile_flags=-O2 -g -Wall -Werror -fdiagnostics-s
how-option  -Wno-unused-function -Wno-char-subscripts -Wno-c++11-extensions -Wno
-unnamed-type-template-args -Wno-extra-semi -Wno-unused-private-field  --defines
=__linux__ "__STDC_LIMIT_MACROS=1" "__STDC_FORMAT_MACROS=1" "_GNU_SOURCE=1" "_BS
D_SOURCE=1" "_POSIX_C_SOURCE=199506" "_XOPEN_SOURCE=600" "DYNAMIC_ANNOTATIONS_EN
ABLED=1" "DYNAMIC_ANNOTATIONS_PREFIX=NACL_" "NACL_BUILD_ARCH=x86" "_WIN32_WINNT=
0x0602" "WINVER=0x0602" WIN32 _WINDOWS NOMINMAX "PSAPI_VERSION=1" _CRT_RAND_S CE
RT_CHAIN_PARA_HAS_EXTRA_FIELDS WIN32_LEAN_AND_MEAN _ATL_NO_OPENGL _SECURE_ATL "_
WIN32_WINNT=0x0600" "WINVER=0x0600" "__STDC_LIMIT_MACROS=1" "NACL_LINUX=0" "NACL
_ANDROID=0" "NACL_OSX=0" "NACL_WINDOWS=1" _CRT_SECURE_NO_DEPRECATE _CRT_NONSTDC_
NO_WARNINGS _CRT_NONSTDC_NO_DEPRECATE _SCL_SECURE_NO_DEPRECATE CHROMIUM_BUILD CO
MPONENT_BUILD "TOOLKIT_VIEWS=1" "USE_LIBJPEG_TURBO=1" ENABLE_ONE_CLICK_SIGNIN "E
NABLE_REMOTING=1" "ENABLE_WEBRTC=1" ENABLE_PEPPER_THREADING ENABLE_CONFIGURATION
_POLICY ENABLE_INPUT_SPEECH ENABLE_NOTIFICATIONS NO_TCMALLOC "ENABLE_GPU=1" "ENA
BLE_EGLIMAGE=1" "USE_SKIA=1" __STD_C "NTDDI_VERSION=0x06020000" "ENABLE_TASK_MAN
AGER=1" "ENABLE_WEB_INTENTS=1" "ENABLE_EXTENSIONS=1" "ENABLE_PLUGIN_INErr 255: n
acl-pnacl-clang ..\..\..\..\out\Debug\obj\native_client\src\shared\platform\plat
form_lib.gen/pnacl_newlib-pnacl/platform_lib\nacl_check.o
>>..\..\..\..\out\Debug\gen\sdk\toolchain\win_x86_pnacl\newlib\bin\pnacl-clang<<
 >>-c<< >>nacl_check.c<< >>-o<< >>../../../../out/Debug/obj/native_client/src/sh
ared/platform/platform_lib.gen/pnacl_newlib-pnacl/platform_lib/nacl_check.o<< >>
-MD<< >>-MF<< >>../../../../out/Debug/obj/native_client/src/shared/platform/plat
form_lib.gen/pnacl_newlib-pnacl/platform_lib/nacl_check.o.d<< >>-std=gnu99<< >>-
O2<< >>-g<< >>-Wall<< >>-Werror<< >>-fdiagnostics-show-option<< >>-Wno-unused-fu
nction<< >>-Wno-char-subscripts<< >>-Wno-c++11-extensions<< >>-Wno-unnamed-type-
template-args<< >>-Wno-extra-semi<< >>-Wno-unused-private-field<< >>-D__linux__<
< >>-D__STDC_LIMIT_MACROS=1<< >>-D__STDC_FORMAT_MACROS=1<< >>-D_GNU_SOURCE=1<< >
>-D_BSD_SOURCE=1<< >>-D_POSIX_C_SOURCE=199506<< >>-D_XOPEN_SOURCE=600<< >>-DDYNA
MIC_ANNOTATIONS_ENABLED=1<< >>-DDYNAMIC_ANNOTATIONS_PREFIX=NACL_<< >>-DNACL_BUIL
D_ARCH=x86<< >>-DNOMINMAX<< >>-DPSAPI_VERSION=1<< >>-D_CRT_RAND_S<< >>-DCERT_CHA
IN_PARA_HAS_EXTRA_FIELDS<< >>-D_ATL_NO_OPENGL<< >>-D_SECURE_ATL<< >>-D__STDC_LIM
IT_MACROS=1<< >>-DNACL_ANDROID=0<< >>-D_CRT_SECURE_NO_DEPRECATE<< >>-D_CRT_NONST
DC_NO_WARNINGS<< >>-D_CRT_NONSTDC_NO_DEPRECATE<< >>-D_SCL_SECURE_NO_DEPRECATE<<
>>-DCHROMIUM_BUILD<< >>-DTOOLKIT_VIEWS=1<< >>-DUSE_LIBJPEG_TURBO=1<< >>-DENABLE_
ONE_CLICK_SIGNIN<< >>-DENABLE_REMOTING=1<< >>-DENABLE_WEBRTC=1<< >>-DENABLE_PEPP
ER_THREADING<< >>-DENABLE_CONFIGURATION_POLICY<< >>-DENABLE_INPUT_SPEECH<< >>-DE
NABLE_NOTIFICATIONS<< >>-DNO_TCMALLOC<< >>-DENABLE_GPU=1<< >>-DENABLE_EGLIMAGE=1
<< >>-DUSE_SKIA=1<< >>-D__STD_C<< >>-DNTDDI_VERSION=0x06020000<< >>-DENABLE_TASK
_MANAGER=1<< >>-DENABLE_WEB_INTENTS=1<< >>-DENABLE_EXTENSIONS=1<< >>-DENABLE_PLU
GIN_INSTALLATION=1<< >>-DENABLE_PLUGINS=1<< >>-DENABLE_SESSION_SERVICE=1<< >>-DE
NABLE_THEMES=1<< >>-DENABLE_BACKGROUND=1<< >>-DENABLE_AUTOMATION=1<< >>-DENABLE_
GOOGLE_NOW=1<< >>-DENABLE_LANGUAGE_DETECTION=1<< >>-DENABLE_PRINTING=1<< >>-DENA
BLE_CAPTIVE_PORTAL_DETECTION=1<< >>-DENABLE_APP_LIST=1<< >>-DENABLE_MESSAGE_CENT
ER=1<< >>-DENABLE_SETTINGS_APP=1<< >>-DNACL_BUILD_SUBARCH=32<< >>-DNACL_BUILD_AR
CH=x86<< >>-DNACL_WINDOWS=0<< >>-DNACL_OSX=0<< >>-DNACL_LINUX=0<< >>-I../../../.
./out/Debug/gen/tc_pnacl_newlib/include<< >>-I../../../..<< >>-I../../../../ppap
i<< >>-I../../../src/third_party<< >>-I../../../..<< >>-I../../../../third_party
/wtl/include<<
STALLATION=1" "ENABLE_PLUGINS=1" "ENABLE_SESSION_SERVICE=1" "ENABLE_THEMES=1" "E
NABLE_BACKGROUND=1" "ENABLE_AUTOMATION=1" "ENABLE_GOOGLE_NOW=1" "ENABLE_LANGUAGE
_DETECTION=1" "ENABLE_PRINTING=1" "ENABLE_CAPTIVE_PORTAL_DETECTION=1" "ENABLE_AP
P_LIST=1" "ENABLE_MESSAGE_CENTER=1" "ENABLE_SETTINGS_APP=1" "NACL_TARGET_SUBARCH
=32" "NACL_TARGET_ARCH=x86" "NACL_BUILD_SUBARCH=32" "NACL_BUILD_ARCH=x86" --link
_flags=-B..\..\..\..\out\Debug/gen/tc_pnacl_newlib/lib   --source-list=pnacl_new
lib.platform_lib.source_list.gypcmd<<

FAILED with 255: ..\..\..\..\out\Debug\gen\sdk\toolchain\win_x86_pnacl\newlib\bi
n\pnacl-clang -c nacl_check.c -o ..\..\..\..\out\Debug\obj\native_client\src\sha
red\platform\platform_lib.gen/pnacl_newlib-pnacl/platform_lib\nacl_check.o -MD -
MF ..\..\..\..\out\Debug\obj\native_client\src\shared\platform\platform_lib.gen/
pnacl_newlib-pnacl/platform_lib\nacl_check.o.d -std=gnu99 -O2 -g -Wall -Werror -
fdiagnostics-show-option -Wno-unused-function -Wno-char-subscripts -Wno-c++11-ex
tensions -Wno-unnamed-type-template-args -Wno-extra-semi -Wno-unused-private-fie
ld -D__linux__ -D__STDC_LIMIT_MACROS=1 -D__STDC_FORMAT_MACROS=1 -D_GNU_SOURCE=1
-D_BSD_SOURCE=1 -D_POSIX_C_SOURCE=199506 -D_XOPEN_SOURCE=600 -DDYNAMIC_ANNOTATIO
NS_ENABLED=1 -DDYNAMIC_ANNOTATIONS_PREFIX=NACL_ -DNACL_BUILD_ARCH=x86 -DNOMINMAX
 -DPSAPI_VERSION=1 -D_CRT_RAND_S -DCERT_CHAIN_PARA_HAS_EXTRA_FIELDS -D_ATL_NO_OP
ENGL -D_SECURE_ATL -D__STDC_LIMIT_MACROS=1 -DNACL_ANDROID=0 -D_CRT_SECURE_NO_DEP
RECATE -D_CRT_NONSTDC_NO_WARNINGS -D_CRT_NONSTDC_NO_DEPRECATE -D_SCL_SECURE_NO_D
EPRECATE -DCHROMIUM_BUILD -DTOOLKIT_VIEWS=1 -DUSE_LIBJPEG_TURBO=1 -DENABLE_ONE_C
LICK_SIGNIN -DENABLE_REMOTING=1 -DENABLE_WEBRTC=1 -DENABLE_PEPPER_THREADING -DEN
ABLE_CONFIGURATION_POLICY -DENABLE_INPUT_SPEECH -DENABLE_NOTIFICATIONS -DNO_TCMA
LLOC -DENABLE_GPU=1 -DENABLE_EGLIMAGE=1 -DUSE_SKIA=1 -D__STD_C -DNTDDI_VERSION=0
x06020000 -DENABLE_TASK_MANAGER=1 -DENABLE_WEB_INTENTS=1 -DENABLE_EXTENSIONS=1 -
DENABLE_PLUGIN_INSTALLATION=1 -DENABLE_PLUGINS=1 -DENABLE_SESSION_SERVICE=1 -DEN
ABLE_THEMES=1 -DENABLE_BACKGROUND=1 -DENABLE_AUTOMATION=1 -DENABLE_GOOGLE_NOW=1
-DENABLE_LANGUAGE_DETECTION=1 -DENABLE_PRINTING=1 -DENABLE_CAPTIVE_PORTAL_DETECT
ION=1 -DENABLE_APP_LIST=1 -DENABLE_MESSAGE_CENTER=1 -DENABLE_SETTINGS_APP=1 -DNA
CL_BUILD_SUBARCH=32 -DNACL_BUILD_ARCH=x86 -DNACL_WINDOWS=0 -DNACL_OSX=0 -DNACL_L
INUX=0 -I..\..\..\..\out\Debug/gen/tc_pnacl_newlib/include -I../../../.. -I../..
/../../ppapi -I../../../src/third_party -I../../../.. -I../../../../third_party/
wtl/include

[4756/13215] ACTION base_untrusted: bu... nlib_d1270b745575d26cc673cf875ed2a371

ninja: build stopped: subcommand failed.
Re: [chromium-dev] Missing language defines Gabriel Charette 1/10/13 11:26 AM

What is in your chromium.gyp_env exactly?

Do you have any other environment variables affecting your build?



On Thu, Jan 10, 2013 at 8:36 AM, Jamie Reid <jamie....@gmail.com> wrote:

--
Chromium Developers mailing list: chromi...@chromium.org
View archives, change email options, or unsubscribe:
http://groups.google.com/a/chromium.org/group/chromium-dev

Re: [chromium-dev] Missing language defines Gabriel Charette 1/10/13 11:30 AM



On Thu, Jan 10, 2013 at 2:26 PM, Gabriel Charette <g...@chromium.org> wrote:

What is in your chromium.gyp_env exactly?

Do you have any other environment variables affecting your build?


(oops sorry for double-post, my email hadn't synced and I thought this hadn't gone out...)

Re: [chromium-dev] Missing language defines Jamie Reid 1/10/13 11:36 AM
No problem, I have solved it. The [ and ] caused problems.

I no have a new error. Could you please help with that? It's just above.
Re: [chromium-dev] Missing language defines Gabriel Charette 1/10/13 11:45 AM
I personally do not have nacl enabled in my build environment; perhaps try "disable_nacl=1" in your chromium.gyp_env's GYP_DEFINES block?

Cheers,
Gab