Rename FormAssociatedElement to ListedElement (issue 2546063002 by yurak@google.com)

0 views
Skip to first unread message

yu...@google.com

unread,
Dec 2, 2016, 4:34:43 AM12/2/16
to tk...@chromium.org, blink-...@chromium.org, blink-rev...@chromium.org, chromium...@chromium.org, dglazko...@chromium.org, domi...@chromium.org, gavinp...@chromium.org, har...@chromium.org, jap...@chromium.org, kinuko...@chromium.org, loading...@chromium.org, tyoshin...@chromium.org
Reviewers: tkent
CL: https://codereview.chromium.org/2546063002/

Message:
PTL

Description:
Renamed FormAssociatedElement to ListedElement.

Planning on adding a new interface for form association code called
FormAssociated.h so I'm renaming this to avoid confusion.

BUG=

Affected files (+147, -621 lines):
M third_party/WebKit/Source/core/html/BUILD.gn
D third_party/WebKit/Source/core/html/FormAssociatedElement.h
D third_party/WebKit/Source/core/html/FormAssociatedElement.cpp
M third_party/WebKit/Source/core/html/FormData.cpp
M third_party/WebKit/Source/core/html/HTMLFieldSetElement.h
M third_party/WebKit/Source/core/html/HTMLFieldSetElement.cpp
M third_party/WebKit/Source/core/html/HTMLFormControlElement.h
M third_party/WebKit/Source/core/html/HTMLFormControlElement.cpp
M third_party/WebKit/Source/core/html/HTMLFormControlElementWithState.h
M third_party/WebKit/Source/core/html/HTMLFormControlsCollection.h
M third_party/WebKit/Source/core/html/HTMLFormControlsCollection.cpp
M third_party/WebKit/Source/core/html/HTMLFormElement.h
M third_party/WebKit/Source/core/html/HTMLFormElement.cpp
M third_party/WebKit/Source/core/html/HTMLLabelElement.cpp
M third_party/WebKit/Source/core/html/HTMLObjectElement.h
M third_party/WebKit/Source/core/html/HTMLObjectElement.cpp
A + third_party/WebKit/Source/core/html/ListedElement.h
A + third_party/WebKit/Source/core/html/ListedElement.cpp
M third_party/WebKit/Source/core/html/ValidityState.h
M third_party/WebKit/Source/core/html/forms/FormController.cpp
M third_party/WebKit/Source/core/loader/FormSubmission.cpp
M third_party/WebKit/Source/modules/credentialmanager/PasswordCredential.cpp
M third_party/WebKit/Source/web/WebFormElement.cpp


tk...@chromium.org

unread,
Dec 2, 2016, 8:24:37 AM12/2/16
to yu...@google.com, blink-...@chromium.org, blink-rev...@chromium.org, chromium...@chromium.org, dglazko...@chromium.org, domi...@chromium.org, gavinp...@chromium.org, har...@chromium.org, jap...@chromium.org, kinuko...@chromium.org, loading...@chromium.org, tyoshin...@chromium.org

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/BUILD.gn
File third_party/WebKit/Source/core/html/BUILD.gn (right):

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/BUILD.gn#newcode222
third_party/WebKit/Source/core/html/BUILD.gn:222: "ListedElement.cpp",
Add ListedElement.h too.

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/HTMLFieldSetElement.h
File third_party/WebKit/Source/core/html/HTMLFieldSetElement.h (right):

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/HTMLFieldSetElement.h#newcode44
third_party/WebKit/Source/core/html/HTMLFieldSetElement.h:44: const
ListedElement::List& associatedElements() const;
Rename this function to listedElements().

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/HTMLFieldSetElement.h#newcode68
third_party/WebKit/Source/core/html/HTMLFieldSetElement.h:68: mutable
ListedElement::List m_associatedElements;
Rename this data member to m_listedElements.

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/HTMLFormControlElement.h
File third_party/WebKit/Source/core/html/HTMLFormControlElement.h
(right):

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/HTMLFormControlElement.h#newcode43
third_party/WebKit/Source/core/html/HTMLFormControlElement.h:43: //
ListedElement, and form-associated element implementations should use
form-associated element implementations -> listed element
implementations

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/HTMLFormControlsCollection.cpp
File third_party/WebKit/Source/core/html/HTMLFormControlsCollection.cpp
(right):

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/HTMLFormControlsCollection.cpp#newcode85
third_party/WebKit/Source/core/html/HTMLFormControlsCollection.cpp:85:
const ListedElement::List& associatedElements = formControlElements();
Rename this variable to listedElements.

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/HTMLFormControlsCollection.cpp#newcode147
third_party/WebKit/Source/core/html/HTMLFormControlsCollection.cpp:147:
ListedElement* associatedElement = elementsArray[i];
Rename this variable to listedElement.

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/HTMLFormControlsCollection.h
File third_party/WebKit/Source/core/html/HTMLFormControlsCollection.h
(right):

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/HTMLFormControlsCollection.h#newcode64
third_party/WebKit/Source/core/html/HTMLFormControlsCollection.h:64:
const ListedElement::List& formControlElements() const;
Rename this function to listedElements().

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/HTMLFormElement.cpp
File third_party/WebKit/Source/core/html/HTMLFormElement.cpp (right):

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/HTMLFormElement.cpp#newcode216
third_party/WebKit/Source/core/html/HTMLFormElement.cpp:216:
ListedElement* ListedElement = elements[i];
Rename this variable to listedElement (lower l)

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/HTMLFormElement.cpp#newcode565
third_party/WebKit/Source/core/html/HTMLFormElement.cpp:565:
ListedElement* associatedElement = 0;
Rename this variable to listedElement.

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/HTMLFormElement.cpp#newcode665
third_party/WebKit/Source/core/html/HTMLFormElement.cpp:665: const
ListedElement::List& associatedElements = this->associatedElements();
Rename this variable to listedElements.

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/HTMLFormElement.h
File third_party/WebKit/Source/core/html/HTMLFormElement.h (right):

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/HTMLFormElement.h#newcode101
third_party/WebKit/Source/core/html/HTMLFormElement.h:101: const
ListedElement::List& associatedElements() const;
Rename this function to listedElements().

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/HTMLFormElement.h#newcode132
third_party/WebKit/Source/core/html/HTMLFormElement.h:132: void
collectAssociatedElements(Node& root, ListedElement::List&) const;
Rename this function to collectListedElements().

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/HTMLFormElement.h#newcode158
third_party/WebKit/Source/core/html/HTMLFormElement.h:158:
ListedElement::List m_associatedElements;
Rename this data member to m_listedElements.

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/ListedElement.cpp
File third_party/WebKit/Source/core/html/ListedElement.cpp (right):

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/ListedElement.cpp#newcode283
third_party/WebKit/Source/core/html/ListedElement.cpp:283: const
HTMLElement& toHTMLElement(const ListedElement& associatedElement) {
Rename this argument to listedElement.

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/ListedElement.cpp#newcode289
third_party/WebKit/Source/core/html/ListedElement.cpp:289: const
HTMLElement* toHTMLElement(const ListedElement* associatedElement) {
Rename this argument to listedElement.

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/ListedElement.cpp#newcode294
third_party/WebKit/Source/core/html/ListedElement.cpp:294: HTMLElement*
toHTMLElement(ListedElement* associatedElement) {
Rename this argument to listedElement.

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/core/html/ListedElement.cpp#newcode299
third_party/WebKit/Source/core/html/ListedElement.cpp:299: HTMLElement&
toHTMLElement(ListedElement& associatedElement) {
Rename this argument to listedElement.

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/web/WebFormElement.cpp
File third_party/WebKit/Source/web/WebFormElement.cpp (right):

https://codereview.chromium.org/2546063002/diff/20001/third_party/WebKit/Source/web/WebFormElement.cpp#newcode66
third_party/WebKit/Source/web/WebFormElement.cpp:66: const
ListedElement::List& associatedElements = form->associatedElements();
Rename this variable to listedElements.

https://codereview.chromium.org/2546063002/

yu...@google.com

unread,
Dec 3, 2016, 7:40:29 AM12/3/16
to tk...@chromium.org, blink-...@chromium.org, blink-rev...@chromium.org, chromium...@chromium.org, dglazko...@chromium.org, domi...@chromium.org, gavinp...@chromium.org, har...@chromium.org, jap...@chromium.org, kinuko...@chromium.org, loading...@chromium.org, tyoshin...@chromium.org
Made suggested changes. PTL.

https://codereview.chromium.org/2546063002/

tk...@chromium.org

unread,
Dec 4, 2016, 7:57:10 AM12/4/16
to yu...@google.com, blink-...@chromium.org, blink-rev...@chromium.org, chromium...@chromium.org, dglazko...@chromium.org, domi...@chromium.org, gavinp...@chromium.org, har...@chromium.org, jap...@chromium.org, kinuko...@chromium.org, loading...@chromium.org, tyoshin...@chromium.org

https://codereview.chromium.org/2546063002/diff/60001/third_party/WebKit/Source/core/html/HTMLFormControlsCollection.h
File third_party/WebKit/Source/core/html/HTMLFormControlsCollection.h
(right):

https://codereview.chromium.org/2546063002/diff/60001/third_party/WebKit/Source/core/html/HTMLFormControlsCollection.h#newcode64
third_party/WebKit/Source/core/html/HTMLFormControlsCollection.h:64:
const ListedElement::List& formListedElements() const;
formListedElement() -> listedElement()

https://codereview.chromium.org/2546063002/diff/60001/third_party/WebKit/Source/core/html/HTMLFormElement.h
File third_party/WebKit/Source/core/html/HTMLFormElement.h (right):

https://codereview.chromium.org/2546063002/diff/60001/third_party/WebKit/Source/core/html/HTMLFormElement.h#newcode132
third_party/WebKit/Source/core/html/HTMLFormElement.h:132: void
collectlistedElements(Node& root, ListedElement::List&) const;
collectlistedElement -> collectListedElement

https://codereview.chromium.org/2546063002/

yu...@google.com

unread,
Dec 4, 2016, 8:19:37 PM12/4/16
to tk...@chromium.org, blink-...@chromium.org, blink-rev...@chromium.org, chromium...@chromium.org, dglazko...@chromium.org, domi...@chromium.org, gavinp...@chromium.org, har...@chromium.org, jap...@chromium.org, kinuko...@chromium.org, loading...@chromium.org, tyoshin...@chromium.org

tk...@chromium.org

unread,
Dec 4, 2016, 8:25:27 PM12/4/16
to yu...@google.com, blink-...@chromium.org, blink-rev...@chromium.org, chromium...@chromium.org, dglazko...@chromium.org, domi...@chromium.org, gavinp...@chromium.org, har...@chromium.org, jap...@chromium.org, kinuko...@chromium.org, loading...@chromium.org, tyoshin...@chromium.org

commit-bot@chromium.org via codereview.chromium.org

unread,
Dec 4, 2016, 8:25:42 PM12/4/16
to yu...@google.com, tk...@chromium.org, commi...@chromium.org, blink-...@chromium.org, blink-rev...@chromium.org, chromium...@chromium.org, dglazko...@chromium.org, domi...@chromium.org, gavinp...@chromium.org, har...@chromium.org, jap...@chromium.org, kinuko...@chromium.org, loading...@chromium.org, tyoshin...@chromium.org

commit-bot@chromium.org via codereview.chromium.org

unread,
Dec 4, 2016, 10:15:01 PM12/4/16
to yu...@google.com, tk...@chromium.org, commi...@chromium.org, blink-...@chromium.org, blink-rev...@chromium.org, chromium...@chromium.org, dglazko...@chromium.org, domi...@chromium.org, gavinp...@chromium.org, har...@chromium.org, jap...@chromium.org, kinuko...@chromium.org, loading...@chromium.org, tyoshin...@chromium.org
Committed patchset #5 (id:80001)

https://codereview.chromium.org/2546063002/

commit-bot@chromium.org via codereview.chromium.org

unread,
Dec 4, 2016, 10:16:58 PM12/4/16
to yu...@google.com, tk...@chromium.org, commi...@chromium.org, blink-...@chromium.org, blink-rev...@chromium.org, chromium...@chromium.org, dglazko...@chromium.org, domi...@chromium.org, gavinp...@chromium.org, har...@chromium.org, jap...@chromium.org, kinuko...@chromium.org, loading...@chromium.org, tyoshin...@chromium.org
Patchset 5 (id:??) landed as
https://crrev.com/4ed88b2834497778b8a4e8d73334c0e83cd8307d
Cr-Commit-Position: refs/heads/master@{#436222}

https://codereview.chromium.org/2546063002/
Reply all
Reply to author
Forward
0 new messages