Please check to see if direct access works for you ...

136 views
Skip to first unread message

CamectArup

unread,
Apr 23, 2021, 8:19:02 PMApr 23
to Camect User Forum

If you normally access your device via home.camect.com, please take a moment to see if you can also access directly. We had one user report issues with it, and we'd like to know if anyone else is having problems or if the issues are specific to that user's situation. 

       When you are connected to the same network as the device  you can access directly by any of the following: 
 
                  https://local.home.camect.com/ 
                  https://camect.local/ 
                  https:/IPADDRESS/   (where you have to use the ip address of your device) 


The first method (local.home.camect.com) may not work depending on the DNS configuration in your router. If it doesn't it's fine as long as one of the two others work. 

The second and third methods will produce a browser warning, and you should be able to proceed to a sign in prompt after accepting the warning. You can sign in with the local admin account ... i.e. username "admin" and the password, unless you have changed it from the default, is the userid of the email you used to activate your device, e.g. it will be "joe" if you activated with j...@gmail.com

If it's the first time you're signing in locally, you may need to accept the user agreement for the account. After that, you should be able to see your cameras just as you can on home.camect.com

If you're unable to get a sign in prompt by any of the three methods, or if you can only partially sign in but not get to the point of seeing your cameras, we'd like to hear about it. If all 3 methods fail, access your device via home.camect.com, open the hub settings (cog wheel at top right), and use "Report Bug" to report the issue. 

Thanks! 

Arup

CamectChao

unread,
Apr 23, 2021, 9:08:44 PMApr 23
to Camect User Forum, CamectArup
For those who never accessed the device through the IP address, please follow
- Open hub settings dialog.
- Click "hub name" (with a "i" icon in the top left).
- In the popover, there is a link to the IP. Click it.

Please make sure you are on the same network as the Camect hub before you do it.

Rob Taft

unread,
Apr 23, 2021, 10:55:57 PMApr 23
to CamectChao, Camect User Forum, CamectArup
I was able to connect with the first method.

--
You received this message because you are subscribed to the Google Groups "Camect User Forum" group.
To unsubscribe from this group and stop receiving emails from it, send an email to forum+un...@camect.com.
To view this discussion on the web visit https://groups.google.com/a/camect.com/d/msgid/forum/c737d798-5b96-4910-afbf-9e8365eac54fn%40camect.com.

Wayne Wilson

unread,
Apr 24, 2021, 10:59:57 AMApr 24
to Camect User Forum, CamectArup
All three methods work on Win10 using Chrome, although the last two give certificate warnings as expected.   From my Ipad, I can get to all three web sites (same certificate errors you have to override) but I cannot login, the first two times I tried, I got bounced right back to the login prompt.  Just now I tried it again to see what the error was, if any, any this time I got the WebRTC failed endless loop on camect.local and IP address, but got through on local.home.camect.com (which redirected to longnumber.l.home.camect.com.) 

Eric Meeson

unread,
Apr 24, 2021, 12:40:47 PMApr 24
to Camect User Forum, CamectArup
Mine is functional with all three methods

On Friday, April 23, 2021 at 8:19:02 PM UTC-4 CamectArup wrote:

CamectArup

unread,
Apr 24, 2021, 4:09:55 PMApr 24
to Camect User Forum
I should have mentioned that methods #2 and #3 won't work on iOS devices. Apple is "protecting" you from doing webRTC to addresses that would produce a certificate warning. I'm not aware of any way to tell it that you're okay with the risk. 

Thanks to everyone who has checked so far. We're still interested in getting bug reports from anyone that finds that none of the methods are working. 

ZzyzxOh

unread,
Apr 24, 2021, 5:23:29 PMApr 24
to Camect User Forum, CamectArup
All methods working once I remembered (from your note) how to input my password.

Devesh Batra

unread,
May 13, 2021, 3:21:27 PMMay 13
to Camect User Forum, ZzyzxOh, CamectArup
all 3 options worked i have the unit in a different VLAN and my Firewalla Router was able to resolve DNS and let me login
MacBook / Chrome Browser

Arup Mukherjee

unread,
May 13, 2021, 4:12:31 PMMay 13
to Devesh Batra, Camect User Forum
Thanks ... As of the last software update we believe we've resolved the issue that was, on rare occasions, causing systems to not be accessible directly. 

Joe Rose

unread,
Jul 6, 2021, 1:05:56 AMJul 6
to Camect User Forum, CamectArup
In Safari on OSX, go to the "Develop" menu, "WebRTC" item and "Disable ICE candidate restrictions". That solved the problem for me using the local IP.

If you don't have the "Develop" menu, go to Safari's preferences, 'Advanced' tab and at the bottom 'show Develop menu in menubar'

On Saturday, April 24, 2021 at 4:09:55 PM UTC-4 CamectArup wrote:

Arup Mukherjee

unread,
Jul 6, 2021, 1:06:05 AMJul 6
to Joe Rose, Camect User Forum
Awesome ... Thanks for sharing. Are you aware of any way to do something similar under iOS, which also refuses to let WebRTC connect directly to an IP address? 


Reply all
Reply to author
Forward
0 new messages