From an API consumer, rather than mathematical, perspective,
Fractional + Trig seems to be what you need to rewrite existing code
framed in terms of Doubles into a generic form, and still have the
core operations provided by Scala/Java available.
So IMHO it should be short, an abbreviation/alias for a bundling of
stuff that's commonly used together. Purists can use the more fine
grained constituent type-classes. Perhaps..
Fract
FNum
Flot
FractionalT
-Ben