Idea regarding method name

33 Aufrufe
Direkt zur ersten ungelesenen Nachricht

julius

ungelesen,
21.09.2012, 07:51:3021.09.12
an scala...@googlegroups.com

Hi,

When we want to check the state when doing something, the method might be named as
checkStateIsAtWhen(state,action), It seems it is not so nice to understand it. if we can write like
checkSateIsAt(state)When(action), it could be more descriptive and easy to read.
 
Is it possible implemented in scala
 

Thanks

Julius

Allen antworten
Antwort an Autor
Weiterleiten
0 neue Nachrichten