I doubt we should be taking up the users' precious namespace with things
that aren't standardly prefixed.
It's likely that the p6ge_compile should be in P6GE, and that P6GEMatch
should be P6GE::Match (that is, [ "P6GE", "Match" ]).
Anyone disagree?
Luke
Looks great to me -- I'll switch things around to (pardon the pun) match.
They'll become "P6GE::compile" (compiler sub) and "P6GE::Match", with
a note that P6GE::compile is still subject to change.
Also, since the library search path for load_bytecode has now been fixed,
it's probably worthwhile to move the p6ge.pir file into
runtime/parrot/library. I'm guessing it should become
runtime/parrot/library/P6GE.pir (note uppercase) since it's now
defining the P6GE:: namespace, but could someone confirm this for
me before I make the change?
Pm
- still discovering all of the conventions
Well, since we're nitpicking conventions and consistency, what about:
PGE::compile
and PGE::match (instead of Match)
Jerome
--
jqu...@mongueurs.net
As Luke mentioned, "Match" is uppercase because it's a class.
However, I ended up naming the compilation routines based on what
they compile -- i.e., "p6rule", "p5re", and "glob". Note that this
may or may not eventually correspond to the string name that is
used as part of the C<compreg> opcode -- that's still to be worked
out.
Pm
Probably because PGE::compile is a sub and PGE::Match is a class :-)
Luke