Google Groups no longer supports new Usenet posts or subscriptions. Historical content remains viewable.
Dismiss

[perl #38593] [TODO] JIT compiler improvements

4 views
Skip to first unread message

Leopold Toetsch

unread,
Feb 19, 2006, 6:28:32 PM2/19/06
to bugs-bi...@rt.perl.org
# New Ticket Created by Leopold Toetsch
# Please include the string: [perl #38593]
# in the subject line of all future correspondence about this issue.
# <URL: https://rt.perl.org/rt3/Ticket/Display.html?id=38593 >


The JIT compiler tools/build/jit2h.pl creates src/{jit,exec}_cpu.c from
src/jit/*/core.jit by expanding some macros and templates, creating JIT
opcode functions and generating a table of these.

There are several possibilities for improvements, but be warned - some
are hard(er).

Easy bits:

*) jit2h.pl doesn't create a .h file - a better util name couldn't harm

*) warn about an attempt to create non-existing opcodes

I had e.g. defined Parrot_sqrt_n but there is no such opcode sqrt_n
(it's sqrt_n_n).
The JIT compiler should emit a warning for such cases

*) tidy perl code - only the visuals - no functional changes

Hard ones:

*) unify macros across architectures and jit/exec

jit/exec has some differences but not that much as handled inside
jit2h.pl

*) cleanup jit2h.pl functionality

the code is a mess with a lot of addons and exceptions

All need testing on ppc and x86 to verify changes with 'make testj'.
(exec is for sure broken but fixable later).

Thanks,
leo

Joshua Hoblitt

unread,
Feb 19, 2006, 7:31:24 PM2/19/06
to perl6-i...@perl.org
On Sun, Feb 19, 2006 at 03:28:32PM -0800, Leopold Toetsch wrote:
> *) jit2h.pl doesn't create a .h file - a better util name couldn't harm

I've renamed it to jit2c.pl and added a JIT_BUILD_TOOL var in the root
makefile so the path of this utility is no longer repeated encoded.

-J

--

0 new messages