Proposal for 1.0: Cleanup of userID casing issues for Account to match all other data objects

0 views
Skip to first unread message

goosemanjack

unread,
Oct 16, 2009, 6:27:10 PM10/16/09
to OpenSocial - OpenSocial and Gadgets Specification Discussion
There are casing mis-matches in the data format specified in the REST
spec for the userId field.

The Account object specifies "userid" (all lower case).
http://www.opensocial.org/Technical-Resources/opensocial-spec-v09/REST-API.html#accountElement

All the other data objects appear to specify "userId" (mixed case on
Id)

Ex: Activity object specifies "userId"
http://www.opensocial.org/Technical-Resources/opensocial-spec-v09/REST-API.html#rfc.section.11.2.1


Proposal is to normalize Account.userid to Account.userId (mixed case
on Id) to match all other data objects.

Adam Winer

unread,
Oct 18, 2009, 6:27:36 PM10/18/09
to opensocial-an...@googlegroups.com
+1; I'd call that a typo on the account element.

Lane

unread,
Oct 28, 2009, 8:36:04 PM10/28/09
to OpenSocial - OpenSocial and Gadgets Specification Discussion
+1

On Oct 18, 3:27 pm, Adam Winer <awi...@gmail.com> wrote:
> +1;  I'd call that a typo on the account element.
>
> On Fri, Oct 16, 2009 at 3:27 PM, goosemanjack <cc...@myspace.com> wrote:
>
> > There are casing mis-matches in the data format specified in the REST
> > spec for the userId field.
>
> > The Account object specifies "userid" (all lower case).
> >http://www.opensocial.org/Technical-Resources/opensocial-spec-v09/RES...
>
> > All the other data objects appear to specify "userId" (mixed case on
> > Id)
>
> > Ex: Activity object specifies "userId"
> >http://www.opensocial.org/Technical-Resources/opensocial-spec-v09/RES...

Chris Chabot

unread,
Oct 29, 2009, 9:10:35 AM10/29/09
to opensocial-an...@googlegroups.com
+1

--

You received this message because you are subscribed to the Google Groups "OpenSocial and Gadgets Specification Discussion" group.
To post to this group, send email to opensocial-an...@googlegroups.com.
To unsubscribe from this group, send email to opensocial-and-gadg...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/opensocial-and-gadgets-spec?hl=en.



Arne Roomann-Kurrik

unread,
Oct 29, 2009, 2:29:55 PM10/29/09
to opensocial-an...@googlegroups.com
+1

Jorge Reyes

unread,
Nov 2, 2009, 1:56:46 PM11/2/09
to opensocial-an...@googlegroups.com
+1

goosemanjack

unread,
Nov 3, 2009, 6:18:47 PM11/3/09
to OpenSocial - OpenSocial and Gadgets Specification Discussion
Created spec patch

http://codereview.appspot.com/143082

Also included normalizing currentLocation in person to location as all
other object types use this field.
--
clc


On Nov 2, 10:56 am, Jorge Reyes <jer...@gmail.com> wrote:
> +1
>
> On Thu, Oct 29, 2009 at 11:29 AM, Arne Roomann-Kurrik <kur...@google.com>wrote:
>
> > +1
>
> > On Thu, Oct 29, 2009 at 6:10 AM, Chris Chabot <chab...@google.com> wrote:
>
> >> +1
>
> >> On Thu, Oct 29, 2009 at 1:36 AM, Lane <lliab...@google.com> wrote:
>
> >>> +1
>
> >>> On Oct 18, 3:27 pm, Adam Winer <awi...@gmail.com> wrote:
> >>> > +1;  I'd call that a typo on the account element.
>
> >>> > On Fri, Oct 16, 2009 at 3:27 PM, goosemanjack <cc...@myspace.com>
> >>> wrote:
>
> >>> > > There are casing mis-matches in the data format specified in the REST
> >>> > > spec for the userId field.
>
> >>> > > The Account object specifies "userid" (all lower case).
>
> >>>http://www.opensocial.org/Technical-Resources/opensocial-spec-v09/RES...
>
> >>> > > All the other data objects appear to specify "userId" (mixed case on
> >>> > > Id)
>
> >>> > > Ex: Activity object specifies "userId"
>
> >>>http://www.opensocial.org/Technical-Resources/opensocial-spec-v09/RES...
>
> >>> > > Proposal is to normalize Account.userid to Account.userId (mixed case
> >>> > > on Id) to match all other data objects.
>
> >>> --
>
> >>> You received this message because you are subscribed to the Google Groups
> >>> "OpenSocial and Gadgets Specification Discussion" group.
> >>> To post to this group, send email to
> >>> opensocial-an...@googlegroups.com.
> >>> To unsubscribe from this group, send email to
> >>> opensocial-and-gadg...@googlegroups.com<opensocial-and-gadgets-spec%2Bunsu...@googlegroups.com>
> >>> .
> >>> For more options, visit this group at
> >>>http://groups.google.com/group/opensocial-and-gadgets-spec?hl=en.
>
> >>  --
> >> You received this message because you are subscribed to the Google Groups
> >> "OpenSocial and Gadgets Specification Discussion" group.
> >> To post to this group, send email to
> >> opensocial-an...@googlegroups.com.
> >> To unsubscribe from this group, send email to
> >> opensocial-and-gadg...@googlegroups.com<opensocial-and-gadgets-spec%2Bunsu...@googlegroups.com>
> >> .
> >> For more options, visit this group at
> >>http://groups.google.com/group/opensocial-and-gadgets-spec?hl=en.
>
> >  --
> > You received this message because you are subscribed to the Google Groups
> > "OpenSocial and Gadgets Specification Discussion" group.
> > To post to this group, send email to
> > opensocial-an...@googlegroups.com.
> > To unsubscribe from this group, send email to
> > opensocial-and-gadg...@googlegroups.com<opensocial-and-gadgets-spec%2Bunsu...@googlegroups.com>
> > .

Lane LiaBraaten

unread,
Nov 3, 2009, 8:07:14 PM11/3/09
to opensocial-an...@googlegroups.com
+1

To unsubscribe from this group, send email to opensocial-and-gadg...@googlegroups.com.

Chris Chabot

unread,
Nov 4, 2009, 4:21:29 AM11/4/09
to opensocial-an...@googlegroups.com
+1

Jorge Reyes

unread,
Nov 4, 2009, 8:09:59 PM11/4/09
to opensocial-an...@googlegroups.com
+1

Lane LiaBraaten

unread,
Nov 10, 2009, 12:21:42 PM11/10/09
to opensocial-an...@googlegroups.com
Reply all
Reply to author
Forward
0 new messages