> I was thinking about expressing some hiphop-related musical concepts using
> MO and I have some questions. Let's say i want to express that KRS-One's
> track "South Bronx" sampled James Brown's track "Get Up off a that Thang"
>
> "South Bronx" is mo:Track
> "Get Up off a That Thing" is mo:Track
> "South Bronx" mo:sampled "Get Up off a That Thing"
>
> However, the domain of mo:sampled (mo:MusicArtist) doesn't allow this. Is
> this not the intent of mo:sampled??? Maybe I am misunderstanding. also the
> inverse property seems to have a confusing name - mo:sampler.
Hmm, yes - mo:sampled is a bit ambiguous (as is its inverse). I guess
its main aims was to represent an advanced relationship in Musicbrainz
- Fred?
We clearly need a better way to deal with that.
The simplest would be, as you say, a simple link from a Signal (or a
Track?) to the sampled signal (or track) (on a side-note, I'd guess it
would make more sense at the signal level, here):
mo:sample ?
You can also use temporal decomposition here to specify which part
holds which sample (by splitting the signal timeline with events
having the sampled signal as a factor). Let me know if you need a code
snippet for that, I might have that somewhere.
> In fact, I
> would be more interested in using the inverse property to create a list of
> all the tracks that sample James Brown's "Get Up off a that Thing". it
> seems mo:sampledBy might be a good name for this. Also, it seems the
> property mo:remix_of is not appropriate for this case because a remix is
> quite distinct from sampling - "South Bronx" is _not_ a remix of "Get up of
> a that thing"
>
> Also, it seems mo:sampled_version could be renamed mo:digitized_version or
> something to avoid confusion between analog/digital sampling and creative
> sampling. Just a thought.
Good point. I would have hope that the domain/range would disambiguate
that, but I guess it can be changed (and perhaps leave
mo:sampled_version as an alias).
Cheers!
y
>> I was thinking about expressing some hiphop-related musical concepts using
>> MO and I have some questions. Let's say i want to express that KRS-One's
>> track "South Bronx" sampled James Brown's track "Get Up off a that Thang"
>>
>> "South Bronx" is mo:Track
>> "Get Up off a That Thing" is mo:Track
>> "South Bronx" mo:sampled "Get Up off a That Thing"
>>
>> However, the domain of mo:sampled (mo:MusicArtist) doesn't allow this. Is
>> this not the intent of mo:sampled??? Maybe I am misunderstanding. also the
>> inverse property seems to have a confusing name - mo:sampler.
>>
>
> Hmm, yes - mo:sampled is a bit ambiguous (as is its inverse). I guess
> its main aims was to represent an advanced relationship in Musicbrainz
> - Fred?
>
>
Exact.
I would think that everything come from the fact that we said, long time
ago, that the analog signal itself is sampled and not a "track". In
fact, in that case, the "track" is the recorded version of a "sampled"
analog signal, no?
So it is why sample/sampler are related to mo:Signal, and sample_version
and sample_version_of are related to analog and digital signals.
(and not mo:Track).
This has to do with the principles of FRBR I think.
Or am I missing something?
If so then we could consider to create another shortcut in MO?
> We clearly need a better way to deal with that.
> The simplest would be, as you say, a simple link from a Signal (or a
> Track?) to the sampled signal (or track) (on a side-note, I'd guess it
> would make more sense at the signal level, here):
> mo:sample ?
>
Is it not what we currently have with mo:sample_version and
mo:sample_version_of? it relates an AnalogSignal to a DigitalSignal (and
but singes are mo:Signal).
The question of relating them to mo:Track directly is totally another one.
> You can also use temporal decomposition here to specify which part
> holds which sample (by splitting the signal timeline with events
> having the sampled signal as a factor). Let me know if you need a code
> snippet for that, I might have that somewhere.
>
>
>
>> In fact, I
>> would be more interested in using the inverse property to create a list of
>> all the tracks that sample James Brown's "Get Up off a that Thing". it
>> seems mo:sampledBy might be a good name for this. Also, it seems the
>>
what about mo:sampler?
I am the sampler of these signals....
These singals have been sampled by me....
>> property mo:remix_of is not appropriate for this case because a remix is
>> quite distinct from sampling - "South Bronx" is _not_ a remix of "Get up of
>> a that thing"
>>
>> Also, it seems mo:sampled_version could be renamed mo:digitized_version or
>> something to avoid confusion between analog/digital sampling and creative
>> sampling. Just a thought.
>>
>
> Good point. I would have hope that the domain/range would disambiguate
> that, but I guess it can be changed (and perhaps leave
> mo:sampled_version as an alias).
>
Possibly.
Take care,
Fred
> > Hmm, yes - mo:sampled is a bit ambiguous (as is its inverse). I guess
> > its main aims was to represent an advanced relationship in Musicbrainz
> > - Fred?
> >
> >
> Exact.
>
> I would think that everything come from the fact that we said, long time
> ago, that the analog signal itself is sampled and not a "track". In
> fact, in that case, the "track" is the recorded version of a "sampled"
> analog signal, no?
>
> So it is why sample/sampler are related to mo:Signal, and sample_version
> and sample_version_of are related to analog and digital signals.
Well, yes, but here Kurt is not trying to express the relationship
between an analog signal and the corresponding digitized one, but the
relationship between some signals and a signal that borrows some part
of it (sampling in the hip-hop sense, i guess).
We do have the relationships sampled and sampler
(http://musicontology.com/#term_sampled), which link a person to a
signal, which is again not the same thing (btw, does musicbrainz
really use that advanced relationship with a person as its domain - I
didn't succeed to find one).
What Kurt needs, from what I understand, is more something like:
http://zitgist.com/music/signal/2422d804-d518-41a0-8773-eff81806b16
mo:sample http://zitgist.com/music/signal/a941e709-40c6-474f-adfe-cb74a275e096
(mo:sample is perhaps a bit confusing if we leave mo:sampled and mo:sampler)
A property linking a signal to a signal.
So, yes, this would be a neat shortcut property (in case we don't want
to go into more details).
Cheers!
y
what about mo:sampler?
http://zitgist.com/music/signal/2422d804-d518-41a0-8773-eff81806b16
mo:sample http://zitgist.com/music/signal/a941e709-40c6-474f-adfe-cb74a275e096