Add:
output alert_fast: /dir/dir/snortalert.fast
to your snort.conf. It’s not syslog, but better.
James
It’s actually pretty easy to suppress these in OSSEC. I have a couple rules, but the one I use for ignoring these syslog events that trigger OSSEC rule id 1002 (error somewhere in the system):
<rule id="101000" level="0">
<if_sid>1002</if_sid>
<program_name>^snort</program_name>
<match>Check for Bounce Attacks:|Bad Message Direction Alert:|Bad Payload Size Alert:|Bad Chk Sum:|Bad TTL:|Bad autodetects:|Bad handshakes:</match>
<description>Ignoring syslog events from snort startup</description>
</rule>
From: Phil Daws [mailto:ux...@splatnix.net]
Sent: Thursday, April 04, 2013 11:50 AM
To: Jeremy Hoel
Cc: snort...@lists.sourceforge.net
Subject: Re: [Snort-users] Snort and Syslog
Hi Jeremy,
How many rules would be require in OSSEC to suppress those entries! ;) The issue is how to make Snort write to a different file than syslog. I do not wish to suppress the Snort info just redirect to a different file so that I can pick the juicy bits out to monitor. Appreciate the input.
Thanks.
From: "Jeremy Hoel" <jth...@gmail.com>
To: "Phil Daws" <ux...@splatnix.net>
Cc: snort...@lists.sourceforge.net
Sent: Thursday, 4 April, 2013 4:45:24 PM
Subject: Re: [Snort-users] Snort and Syslog
In OSSEC make a local rule to ignore the file and the process?
Or setup snort to not output to syslog..
and you might try running snort with the '-q' flag and see if it's quieter in the logs.