Branch: refs/heads/master
Home:
https://github.com/openSUSE/kiwi
Commit: cc70daae3b60433ce612d5a891b36a7016f398a9
https://github.com/openSUSE/kiwi/commit/cc70daae3b60433ce612d5a891b36a7016f398a9
Author: Marcus Schäfer <
m...@suse.de>
Date: 2013-05-18 (Sat, 18 May 2013)
Changed paths:
M modules/KIWIImage.pm
M modules/KIWIImageCreator.pm
M modules/KIWIXML.pm
M tests/unit/lib/Test/kiwiXML.pm
Log Message:
-----------
- restructure the use of prebuilt boot images
* adapt to new data structure thus we get rid of
checkAndSetupPrebuiltBootImage, getDefaultPrebuiltDir_legacy
* moved the logic for using a prebuilt version of a boot image
into the image creator code at the level of prepareBootImage
and createBootImage. This saves us one KIWIXML instance
* write one function createImageBootImage which does either
the prepare/create of the boot image or the use of an existing
prebuilt version. reduces some code duplication