--
You received this message because you are subscribed to the Google Groups "The Java Posse" group.
To post to this group, send email to java...@googlegroups.com.
To unsubscribe from this group, send email to javaposse+...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/javaposse?hl=en.
It equates to 30% less time spent tracking down bugs in code that now doesn't even exist, and the money paid to the developer who does so.
You can do the exact same thought experiment completely in Java.
Which is more likely to get wrong, the for/each loop, or a traditional
for loop? :)
Does this mean that one is perfect? Of course not. Errors can always exist.
--
You received this message because you are subscribed to the Google Groups "The Java Posse" group.
To post to this group, send email to java...@googlegroups.com.
To unsubscribe from this group, send email to javaposse+...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/javaposse?hl=en.
--
You received this message because you are subscribed to the Google Groups "The Java Posse" group.
To post to this group, send email to java...@googlegroups.com.
To unsubscribe from this group, send email to javaposse+...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/javaposse?hl=en.
No, I never stated that, because I don't believe it.Using higher-level concepts with fewer *tokens* will reduce the number of bugs. It just so happens that few tokens usually result in shorter code.
In a related topic, sometimes I find myself shortening code so that I
can see the bugs more clearly. I find it very effective.
On Mon, Oct 25, 2010 at 7:04 PM, Kevin Wright <kev.lee...@gmail.com> wrote:No, I never stated that, because I don't believe it.Using higher-level concepts with fewer *tokens* will reduce the number of bugs. It just so happens that few tokens usually result in shorter code.
Thats not what you said
you made a generalised sweeping statement that can only be wrong because nothing in software is ever that simple.
--
You received this message because you are subscribed to the Google Groups "The Java Posse" group.
To post to this group, send email to java...@googlegroups.com.
To unsubscribe from this group, send email to javaposse+...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/javaposse?hl=en.
In the C programming language, the loop is:
while(i!=j) {
if (i > j)
i -= j;
else
j -= i;
}
In ARM assembly, the loop is:
loop CMP Ri, Rj ; set condition "NE" if (i != j),
; "GT" if (i > j),
; or "LT" if (i < j)
SUBGT Ri, Ri, Rj ; if "GT" (greater than), i = i-j;
SUBLT Rj, Rj, Ri ; if "LT" (less than), j = j-i;
BNE loop ; if "NE" (not equal), then loop
--
R. Mark Volkmann
Object Computing, Inc.
On Mon, Oct 25, 2010 at 10:39 PM, Miroslav Pokorny
But equally I could say @Tx, Does this make the code any more or less understandable than @Transactional ?Perhaps I could have a transactional keyword...How can something like 'number of characters' or '30%' make real sense when its comes to something as subjective.
To unsubscribe from this group, send email to javaposse+...@googlegroups.com.
> To unsubscribe from this group, send email to javaposse+...@googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/javaposse?hl=en.
>
>
--
That reminds me of JUnit 4. Supposedly the @Test annotation is a good
thing. I don't see how the ability to create test methods whose names
do not begin with "test" is a good thing.
i guess one could count the ability to create test cases without extending TestCase could count as a positive thing
I wonder though if most people still give their test methods names
that begin with "test". I do. One reason is so the test methods stand
out in my IDE within the list of methods in the class. I want some way
to visually distinguish between test methods and utility methods
within the test class.
I wonder though if most people still give their test methods names
that begin with "test". I do. One reason is so the test methods stand
out in my IDE within the list of methods in the class. I want some way
to visually distinguish between test methods and utility methods
within the test class.
I wonder though if most people still give their test methods names
that begin with "test". I do. One reason is so the test methods stand
out in my IDE within the list of methods in the class. I want some way
to visually distinguish between test methods and utility methods
within the test class.
--Cédric
--
You received this message because you are subscribed to the Google Groups "The Java Posse" group.
To post to this group, send email to java...@googlegroups.com.
To unsubscribe from this group, send email to javaposse+...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/javaposse?hl=en.
2010/10/27 Cédric Beust ♔ <ced...@beust.com>
On Wed, Oct 27, 2010 at 11:55 AM, Mark Volkmann <r.mark....@gmail.com> wrote:
I wonder though if most people still give their test methods names
that begin with "test". I do. One reason is so the test methods stand
out in my IDE within the list of methods in the class. I want some way
to visually distinguish between test methods and utility methods
within the test class.Yes but this can be easily solved with a tool. Writing an updated Eclipse Outline view to group methods by annotations is a matter of a few hours. Hey I might even go ahead and write it myself.The thing is: most of the methods in my tests classes are test methods, so the need for this is not that high, at least to me.As for naming, yes, old habits die hard and it's easy to just start your method name with "test", but I find myself being more and more creative with this now ("shouldThrowException", "userShouldBePresent", etc...). And I always have the handy `description` attribute if I am in a verbose mood (@Test(description = "Make sure we have exactly one user named Smith in the db"), something that you can't do without annotations.I'm sorry, but, yes that can be done without annotations:and before anyone starts screaming "Oh no, not Scala again!"
To unsubscribe from this group, send email to javaposse+...@googlegroups.com.
--
You received this message because you are subscribed to the Google Groups "The Java Posse" group.
To post to this group, send email to java...@googlegroups.com.
To unsubscribe from this group, send email to javaposse+...@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/javaposse?hl=en.