kukuridashi

瀏覽次數:5 次
跳到第一則未讀訊息

Brian Watson

未讀,
2011年6月23日 晚上9:30:582011/6/23
收件者:hon...@googlegroups.com
I'm translating code comments, and although I can't spell out the names of the functions and the objects (due to my NDA), 
I still need help figuring out the main verb in this sentence.

<Function Name>を<Object?>にくくり出し、分岐を不要にする

Is it

Roll up the <Function Name> into the <Object?> and make branching unnecessary


Brian Watson
http://www.google.com/profiles/brian.watson
+1.604.395.4202 (home office), +1.425.246.7888 (cell), +1.425.341.FOTO (messages), brian-momotaro (skype)

Minoru Mochizuki

未讀,
2011年6月23日 晚上10:21:062011/6/23
收件者:hon...@googlegroups.com

In response to Brian Watson’s query:

 

<Function Name><Object?>にくくり出し、分岐を不要にする

 

Is itRoll up the <Function Name> into the <Object?> and make branching unnecessary?

 

 

The transitive verb くくる generally means “to bundle,” “to group,”  or “to treat (the group) separately from others.”

 

Minoru Mochizuki

 

Jonathan

未讀,
2011年6月24日 上午8:57:142011/6/24
收件者:Honyaku E<>J translation list
On Jun 24, 10:30 am, Brian Watson <brian.wat...@gmail.com> wrote:
> <Function Name>を<Object?>にくくり出し、分岐を不要にする

Initial Google results for くくり出す seem to indicate that in algebra it's
used to refer to "factoring out" or "pulling out" common elements; for
example, given the expression 2x+2, you can くくり出すthe 2, yielding 2(x
+1).

By analogy, I would assume that in programming it refers to the
programming pattern along the following lines. If you want to be able
to calculate the areas of a variety of different polygons, you could
use a chained conditional structure (the 分岐 in your sentence) like
this, given a Shape s:

if(s.type == square)
area = squareArea(s);
else if(s.type == circle)
area = circleArea(s);
else if(s.type == triangle)
area = triangleArea(s);
...

But since that's poor programming practice (poor extensibility, etc.),
one might fold the area calculation into the Shape class as an
abstract method to be implemented by subclasses of Shape.

area = s.area();

I seem to have used "fold into" to correspond to くくり出す but I'm sure
there are are a ton of possibilities using words like include,
implement, work in, factor in, etc., depending on the particulars of
the sentence. Roll up? Sure, why not? Programmers tend to use
rather 直感的 words for these things, so whatever feels right to you.

Jonathan

----------
Jonathan Michaels
Mito, Ibaraki

Brian Watson

未讀,
2011年6月24日 下午1:37:592011/6/24
收件者:hon...@googlegroups.com
2011/6/24 Jonathan <ist...@gmail.com>

I seem to have used "fold into" to correspond to くくり出す but I'm sure
there are are a ton of possibilities using words like include,
implement, work in, factor in, etc., depending on the particulars of
the sentence.  Roll up?  Sure, why not?  Programmers tend to use
rather 直感的 words for these things, so whatever feels right to you.

Thank you, Jonathan.

That helps a lot.

Minoru Mochizuki

未讀,
2011年6月24日 下午5:05:352011/6/24
收件者:hon...@googlegroups.com
Jonathan's suggestion failed to clarify the portion分岐を不要にする, when he
suggested "factoring out" or "pulling out" common elements for くくり出し in
response to Brian Watson' query onくくり出し、分岐を不要にする.

I suppose that 分岐を不要にする means "to make branching unnecessary."
I previously suggested that くくる means "to bundle" or "to group."

Thus, I am suggesting here "to bundle (or group) <functions> together to
make branching unnecessary."

Minoru Mochizuki

Joshua Rothenberg

未讀,
2011年7月1日 下午1:17:082011/7/1
收件者:Honyaku E<>J translation list
Could this be referring to inlining the function?

Joshua Rothenberg

On Jun 23, 9:30 pm, Brian Watson <brian.wat...@gmail.com> wrote:
> I'm translating code comments, and although I can't spell out the names of
> the functions and the objects (due to my NDA),
> I still need help figuring out the main verb in this sentence.
>
> <Function Name>を<Object?>にくくり出し、分岐を不要にする
>
> Is it
>
> Roll up the <Function Name> into the <Object?> and make branching
> unnecessary
>
> ?
>
> Brian Watsonhttp://www.google.com/profiles/brian.watson
回覆所有人
回覆作者
轉寄
0 則新訊息