"Block" and "function" already have pretty well defined meanings to
software engineers; I don't think that re-using the terms but changing
the definitions makes a whole lot of sense in the context of a new
programming language (the engineering definition of "function" is
basically the same as "subroutine," which is sad because "function"
would actually fit pretty well if it didn't have all the baggage).
I would personally prefer to learn a "new" term (in the sense that
If it doesn't map closely, though, I think that nelogism makes more
If we're going for overly clever, I'd like to suggest "rill", as it's
On Wed, May 23, 2012 at 3:53 PM, Ian Wright <wrig...@acm.org> wrote:
> "Block" introduces a new term peculiar to Flow. You'd be introducing a
> "Morphism", in contrast, is a well-defined term already in use.
> What's wrong with "function"?
You must Sign in before you can post messages.
To post a message you must first join this group.
Please update your nickname on the subscription settings page before posting.
You do not have the permission required to post.