In my own code, when I see this:
evt.mapE(function(x) { ... do not return ... });
I usually know that the mapE is only useful for its side-effects. I agree that it would be clearer if we had an actionE. Other names? consumerE? doE?
I find insertDomE useless half the time; all it does it provide an *illusion* of purity.
This is an example of insertDomE being *useful*, since the element itself is time-varying:
insertDomE(timerB(1000).liftB(function(t) { return DIV(String(t)); }), 'target');
But, I often use insertDomE in the following manner:
insertDomE(DIV(timerB(1000).liftB(function(t) { return String(t); }), 'target');
Above, insertDomE does nothing useful since the DIV is static (even though its internals are time-varying).
Therefore, it is equivalent to:
targetParent.appendChild(DIV(timerB(1000).liftB(function(t) { return String(t); }));
I think the latter is better code.