Hi all,
We are currently working on a GOTM-lake case study. We have observed temperature and oxygen profiles that we would like to compare with simulated output (e.g. by AED), and we would like to avoid having simulated oxygen relaxed to the observed profiles.
I have therefore included a fabm_input.nml file in the set up, which contains:
!
! Input file for FABM state variables for comparison to model simulations
!
&observations
variable = 'aed_oxygen_oxy'
file = 'do_prof_file.dat'
/
The do_prof_file.dat includes observation data, which has been set up to match GOTM observation file format (as described on pages 18-21 in the EU MEECE fabm report). This observation data is seemingly being read, as I will get errors if the text string for the observed state variable do not match a state variable name in the models included in the fabm set up.
Simulations finish successfully, but when viewing data in PyNcView I am not able to find the observed oxygen data (only the simulated state variables appear, e.g. 'aed_oxygen_oxy'). Is there a way to include fabm-related observation data as a record in PyNcView?
Cheers
Dennis
Hi Dennis,
In general, adding save_inputs=.true. to gotm_fabm.nml should make the variables in fabm_input.nml show up in NetCDF. However, that has been tested only with input variables that have no internal model equivalent. If your inputs match model variables, save_inputs may cause name clashes in NetCDF. If you run into problems, let me know, and I’ll try to address these.
Cheers,
Jorn
--
You received this message because you are subscribed to the Google Groups "FABM-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to fabm-users+...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
We tried adding save_inputs=.true. to gotm_fabm.nml just now. This caused an immediate crash during runtime as you also imply - text dump from log screen:
Reading observed values for variable aed_oxygen_oxy from do_prof_file2.dat
done
NetCDF: String match to name in use
cheers
Dennis
Hi Dennis,
I’ve just appended “_obs” to the name of input variables included in NetCDF. Hopefully that fixes the name clash. Fix in the gotm repository. But please treat details such as “save_inputs” and the “_obs” postfix as experimental and likely to change; the functionality to save inputs will remain, but naming conventions could be improved.
Cheers