Instead of the following:
ordering = (('pub_date', 'ASC'), ('name', 'DESC'), ('other',
What do you think of this syntax?
ordering = ('pub_date+', 'name-', 'other?')
This syntax would be used when declaring default ordering in models
(via the "ordering" argument), and it'd be used in the "order_by"
parameter to the database API.
I like it because it's a lot less crufty, easier to type and easier to
The change can even be backwards-compatible if we wanted it to be,
although I'd want to phase out the old-style ordering eventually.