On 11.01.2010, at 11:44, Dirkjan Ochtman wrote:
> Before the holiday I was speaking a bit with Christopher in IRC aboutYeah, in retrospect I think the "schema" name was a really bad choice. I'd suggest we move to "mapping", as in mapping JSON to Python objects and back. So the couchdb.schema module would become couchdb.mapping, and the "Schema" class would be renamed to "Mapping". Also, it'd be nice to rename the couchdb.schema.Document class so that it isn't as easily confused with couchdb.client.Document. Maybe DocumentMapping? Not sure what to do with couchdb.schema.View.
> what he was envisioning for couchdb-python's next release. I'd like to
> start moving on some things again, but it would be nice to move the
> stuff we agreed on out of the way first.
> But of course I didn't log that conversation at the time and I don't
> - Break compatibility by renaming couchdb.schema to something more
> - Something in the Database needs to be changed from "session" toThat's just a change that already happened httplib branch. Needs to be documented together with other backwards incompatible changes.
> "http" or the other way around, I forget what it was
> - Merge the httplib branch into the default branchThanks,
> - Fix some API consistencies (method calls vs. properties -> should
> all become method calls)
> After this, the idea was to declare the API somewhat-more stable by
cmlenz at gmx.de
You must Sign in before you can post messages.
To post a message you must first join this group.
Please update your nickname on the subscription settings page before posting.
You do not have the permission required to post.