Google Groups no longer supports new Usenet posts or subscriptions. Historical content remains viewable.
Dismiss

for: else: - any practical uses for the else clause?

3 views
Skip to first unread message

metape...@gmail.com

unread,
Sep 26, 2006, 4:59:48 PM9/26/06
to
A very old thread:
http://groups.google.com/group/comp.lang.python/browse_frm/thread/2c5022e2b7f05525/1542d2041257c47e?lnk=gst&q=for+else&rnum=9#1542d2041257c47e

discusses the optional "else:" clause of the for statement.

I'm wondering if anyone has ever found a practical use for the else
branch?

sk...@pobox.com

unread,
Sep 26, 2006, 5:07:30 PM9/26/06
to metape...@gmail.com, pytho...@python.org

metaperl> I'm wondering if anyone has ever found a practical use for the
metaperl> else branch?

Yeah, I use it from time to time:

for foo in bar:
if foo matches some condition:
print "sail to tahiti!"
break
else:
print "abandon ship!"

Skip

Amaury Forgeot d'Arc

unread,
Sep 26, 2006, 5:15:27 PM9/26/06
to
metape...@gmail.com a écrit :

I use it regularly in contructs like:

for value in someList:
if someCondition(value):
print "a matching item was found"
break
else:
print "no matching item"
return False

# ... continue with value

--
Amaury

Bruno Desthuilliers

unread,
Sep 26, 2006, 6:25:09 PM9/26/06
to
metape...@gmail.com a écrit :
<aol>
Just like Skip and Amaury...
</aol>

Fuzzyman

unread,
Sep 26, 2006, 6:14:34 PM9/26/06
to

Me too...

Same with while loops.

Fuzzyman
http://www.voidspace.org.uk/python/index.shtml

>
> --
> Amaury

Ben Sizer

unread,
Sep 27, 2006, 10:15:08 AM9/27/06
to

As a C++ programmer (which I'm sure undermines my argument before
you've even read it...), this feels 'backwards' to me. Although I am no
purist, the 'else' typically implies failure of a previous explicit
condition, yet in this case, it's executed by default, when the
previous clause was successfully executed. It would seem more natural
if the else clause was triggered by 'bar' being empty, or even if the
loop was explicitly broken out of, though I'm sure that would make the
construct much less useful.

--
Ben Sizer

Sion Arrowsmith

unread,
Sep 28, 2006, 11:26:34 AM9/28/06
to
Ben Sizer <kyl...@gmail.com> wrote:

>sk...@pobox.com wrote:
>> Yeah, I use it from time to time:
>>
>> for foo in bar:
>> if foo matches some condition:
>> print "sail to tahiti!"
>> break
>> else:
>> print "abandon ship!"
>
>As a C++ programmer (which I'm sure undermines my argument before
>you've even read it...), this feels 'backwards' to me. Although I am no
>purist, the 'else' typically implies failure of a previous explicit
>condition, yet in this case, it's executed by default, when the
>previous clause was successfully executed. It would seem more natural
>if the else clause was triggered by 'bar' being empty, [ ... ]

It does:

>>> for foo in []:
... print foo
... else:
... print 'else'
...
else

I think it's clearer to see by comparing while with if:

if False:
do nothing
else:
do something

while False:
do nothing
else:
do something

and getting to the for behaviour from while is trivial.

That said, I've not had much call for it and was kind of surprised to
find myself writing a genuine for ... else the other week. But it was
the obvious way to do the task at hand, and I was happy it was there.

--
\S -- si...@chiark.greenend.org.uk -- http://www.chaos.org.uk/~sion/
___ | "Frankly I have no feelings towards penguins one way or the other"
\X/ | -- Arthur C. Clarke
her nu becomeþ se bera eadward ofdun hlæddre heafdes bæce bump bump bump

metaperl

unread,
Sep 29, 2006, 3:45:55 AM9/29/06
to
Actually right after posting this I came up with a great usage. I use
meld3 for my Python based dynamic HTML generation. Whenever I plan to
loop over a tree section I use a for loop, but if there is no data to
iterate over, then I simply remove that section from the tree or
populate it with a "no data" message.

Klaas

unread,
Sep 29, 2006, 2:26:10 PM9/29/06
to

else: does not trigger when there is no data on which to iterate, but
when the loop terminated normally (ie., wasn't break-ed out). It is
meaningless without break.

Python 2.4.3 (#1, Mar 29 2006, 15:37:23)
[GCC 4.0.2 20051125 (Red Hat 4.0.2-8)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> for x in []:
... print 'nothing'
... else:
... print 'done'
...
done

-Mike

Klaas

unread,
Sep 29, 2006, 5:21:25 PM9/29/06
to
Klaas wrote:

> else: does not trigger when there is no data on which to iterate, but
> when the loop terminated normally (ie., wasn't break-ed out). It is
> meaningless without break.

Sorry, this was worded confusingly. "else: triggers when the loop
terminates normally, not simply in the case that there is no iterated
data".

-Mike

Mike Klaas

unread,
Sep 29, 2006, 5:22:54 PM9/29/06
to Johan Steyn, pytho...@python.org
On 9/29/06, Johan Steyn <johan...@gmail.com> wrote:

> On 29 Sep 2006 11:26:10 -0700, Klaas <mike....@gmail.com> wrote:
>
> > else: does not trigger when there is no data on which to iterate, but
> > when the loop terminated normally (ie., wasn't break-ed out). It is
> > meaningless without break.
>
> The else clause *is* executed when there is no data on which to iterate.
> Your example even demonstrates that clearly:

Yes--there is a missing "just" in that sentence.

-Mike

BJörn Lindqvist

unread,
Sep 29, 2006, 5:32:42 PM9/29/06
to pytho...@python.org
On 9/29/06, Johan Steyn <johan...@gmail.com> wrote:
> I agree that it is meaningless without a break statement, but I still find
> it useful when I want to determine whether I looped over the whole list or
> not. For example, if I want to see whether or not a list contains an odd
> number:
>
> for i in list:
> if i % 2 == 1:
> print "Found an odd number."
> break
> else:
> print "No odd number found."
>
> Without the else clause I would need to use an extra variable as a "flag"
> and check its value outside the loop:

You can use generator comprehension:

if (i for i in list if i % 2 == 1):
print "Found an odd number."
else:
print "No odd number found."

I *think* any() should also work:

if any(i % 2 == 1 in list):
....

And so on. For every use of the for/else clause there exists a better
alternative. Which sums up my opinion about the construct -- if you
are using it, there's something wrong with your code.

--
mvh Björn

Matthew Woodcraft

unread,
Sep 29, 2006, 6:42:01 PM9/29/06
to
bjo...@gmail.com wrote:
> And so on. For every use of the for/else clause there exists a better
> alternative. Which sums up my opinion about the construct -- if you
> are using it, there's something wrong with your code.

How do you transform this?

height = 0
for block in stack:
if block.is_marked():
print "Lowest marked block is at height", height
break
height += block.height
else:
raise SomeError("No marked block")

-M-

Paul Rubin

unread,
Sep 29, 2006, 6:59:40 PM9/29/06
to
Matthew Woodcraft <matt...@chiark.greenend.org.uk> writes:
> How do you transform this?
>
> height = 0
> for block in stack:
> if block.is_marked():
> print "Lowest marked block is at height", height
> break
> height += block.height
> else:
> raise SomeError("No marked block")

Untested:

all_heights = [block.height for block in stack if block.is_marked()]
if all_heights:
height = sum(all_heights)


else:
raise SomeError("No marked block")

Alternatively (lower memory usage for large list):

all_heights = (block.height for block in stack if block.is_marked())
try:
height = all_heights.next()
height += sum(all_heights)
except StopIteration:

Sybren Stuvel

unread,
Sep 30, 2006, 3:49:01 AM9/30/06
to
Paul Rubin enlightened us with:

>> height = 0
>> for block in stack:
>> if block.is_marked():
>> print "Lowest marked block is at height", height
>> break
>> height += block.height
>> else:
>> raise SomeError("No marked block")
>
> all_heights = [block.height for block in stack if block.is_marked()]
> if all_heights:
> height = sum(all_heights)
> else:
> raise SomeError("No marked block")
>
> Alternatively (lower memory usage for large list):
>
> all_heights = (block.height for block in stack if block.is_marked())
> try:
> height = all_heights.next()
> height += sum(all_heights)
> except StopIteration:
> raise SomeError("No marked block")

I must say that the for/else construct is a LOT more readable than the
rewritten alternatives.

Sybren
--
Sybren Stüvel
Stüvel IT - http://www.stuvel.eu/

MonkeeSage

unread,
Sep 30, 2006, 3:56:38 AM9/30/06
to
Sybren Stuvel wrote:
> I must say that the for/else construct is a LOT more readable than the
> rewritten alternatives.

+1

I just wish it had a more intuitive name like "after:" or "then:", as
"else:" seems like a choice between the loop and the other block (but
really the choice is between StopIteration and break).

Regards,
Jordan

Paul Rubin

unread,
Sep 30, 2006, 4:07:44 AM9/30/06
to
Sybren Stuvel <sybr...@YOURthirdtower.com.imagination> writes:
> I must say that the for/else construct is a LOT more readable than the
> rewritten alternatives.

They are all pretty ugly. I prefer the genexp version with a
hypothetical "is_empty" function:

all_heights = (block.height for block in stack if block.is_marked())

if is_empty(all_heights):


raise SomeError("No marked block")

heights = sum(all_heights)

Python generators don't really work the right way for this though.

I've been fooling around with Haskell, so these kinds of constructions
seems more natural to me than explicit for loops.

Peter Otten

unread,
Sep 30, 2006, 4:31:25 AM9/30/06
to
Sybren Stuvel wrote:

I like

def blocks_til_mark(stack):


for block in stack:
if block.is_marked():

return
yield block
raise SomeError
height = sum(block.height for block in blocks_til_mark(stack))

Peter

Peter Otten

unread,
Sep 30, 2006, 4:47:18 AM9/30/06
to
Paul Rubin wrote:

> Sybren Stuvel <sybr...@YOURthirdtower.com.imagination> writes:
>> I must say that the for/else construct is a LOT more readable than the
>> rewritten alternatives.
>
> They are all pretty ugly. I prefer the genexp version with a
> hypothetical "is_empty" function:
>
> all_heights = (block.height for block in stack if block.is_marked())
> if is_empty(all_heights):
> raise SomeError("No marked block")

Such a function would have to rebind the generator:

def check_empty(items):
items = iter(items)
try:
first = items.next()
except StopIteration:
return False
return chain([first], items)

all_heights = check_empty(all_heights)
if not all_heights:
raise SomeError

> heights = sum(all_heights)
>
> Python generators don't really work the right way for this though.

You can make it work, but the result tends to be messy:

from itertools import chain

def raiseiter(exc, *args):
raise exc(*args)
yield None # unreachable
def stop():
raise StopIteration

height = sum(block.height for block in chain(stack, raiseiter(SomeError)) if
(not block.is_marked()) or stop())

Peter

Paul Rubin

unread,
Sep 30, 2006, 4:52:03 AM9/30/06
to
Peter Otten <__pet...@web.de> writes:
> I like
>
> def blocks_til_mark(stack):
> for block in stack:
> if block.is_marked():
> return
> yield block
> raise SomeError
> height = sum(block.height for block in blocks_til_mark(stack))

Oh my, I realize now that I mis-read the original, and my examples
were all wrong. Shows how the explicit loop isn't necessarily so
clear ;-). Note that unlike the original, the loop above fails to set
height = 0 in the case where the exception gets raise.

I'd maybe just scan the stack twice. The rescan is needed only if
there can be blocks with height <= 0. Otherwise, you can just raise
SomeError if height == 0:

height = sum(b.height for b in
itertools.takewhile(lambda: not block.is_marked(), stack))

if height == 0 and True not in (b.is_marked() for b in stack):
raise SomeError

Paul Rubin

unread,
Sep 30, 2006, 4:57:24 AM9/30/06
to
Peter Otten <__pet...@web.de> writes:
> > all_heights = (block.height for block in stack if block.is_marked())
> > if is_empty(all_heights):
> > raise SomeError("No marked block")
>
> Such a function would have to rebind the generator:

Yeah, that's what I mean about generators not working the right way.

> You can make it work, but the result tends to be messy:

I think it's better underneath, but still syntactically ugly, to just
defer the generator creation:

all_heights = lambda:

(block.height for block in stack if block.is_marked())

if is_empty(all_heights ()):


raise SomeError("No marked block")

height = sum(all_heights ())

Now sum and is_empty see two separate generators, so is_empty is
straightforward:

def is_empty(gen):
try:
gen.next()
return True
except StopIteration:
return False

Peter Otten

unread,
Sep 30, 2006, 5:22:53 AM9/30/06
to
Paul Rubin wrote:

> Peter Otten <__pet...@web.de> writes:
>> > all_heights = (block.height for block in stack if
>> > block.is_marked()) if is_empty(all_heights):
>> > raise SomeError("No marked block")
>>
>> Such a function would have to rebind the generator:
>
> Yeah, that's what I mean about generators not working the right way.
>
>> You can make it work, but the result tends to be messy:
>
> I think it's better underneath, but still syntactically ugly, to just
> defer the generator creation:
>
> all_heights = lambda:
> (block.height for block in stack if
> block.is_marked())

You still need the stop() trick to omit the heights after the marked block.

> if is_empty(all_heights ()):
> raise SomeError("No marked block")
> height = sum(all_heights ())
>
> Now sum and is_empty see two separate generators, so is_empty is
> straightforward:
>
> def is_empty(gen):
> try:
> gen.next()
> return True
> except StopIteration:
> return False

Alternatively you can turn all_heights into a list (comprehension) which
makes the test trivial.

I think it will be interesting to see how Python 3000's emphasis on
iterators will affect overall code complexity.

Peter

Paul Rubin

unread,
Sep 30, 2006, 8:04:02 AM9/30/06
to
Peter Otten <__pet...@web.de> writes:
> > all_heights = lambda:
> > (block.height for block in stack if
> > block.is_marked())
>
> You still need the stop() trick to omit the heights after the marked block.

Yeah, that code was based on my earlier mis-read of the original post.
How's this:

def blocks_until_mark():
return itertools.takewhile(lambda block:\
not block.is_marked(), \
stack)

height = sum(b.height for b in blocks_until_mark())
if is_empty(blocks_until_mark()):


raise SomeError("No marked block")

> Alternatively you can turn all_heights into a list (comprehension) which
> makes the test trivial.

Yes, I felt it wasn't in the spirit of the thing to use that memory.

> I think it will be interesting to see how Python 3000's emphasis on
> iterators will affect overall code complexity.

We will need more iterator primitives, which are still evolving.

Carl Banks

unread,
Sep 30, 2006, 12:39:15 PM9/30/06
to
metape...@gmail.com wrote:
> I'm wondering if anyone has ever found a practical use for the else
> branch?

Say you have code that looks like this:

if command.startswith("set"):
do_set_action(command)
elif command.startswith("input"):
do_input_action(command)
elif command.startswith("print"):
do_print_action()
else:
do_general_action()

Now, during refactoring, we note that there's a lot of similarity in
all those if clauses that we can exploit to simplify the code. Let's
ignore the final else clause for now, since it's not similar to the if
and elif clauses (it has no test). We define a mapping of prefixes to
actions, and rewrite the if...elif as a for loop:

command_map = (
("set",do_set_action),
("input",do_input_action),
("print",do_print_action)
)

for keyword,action in command_map:
if command.startswith(keyword):
action(command)
break

Ok, this works great. Now let's come back to that else clause: how do
we translate default case to the for loop? Well, I guess we could set
some sort of flag indicating we got a match.... But wait! We don''t
have to! We can just leave the else clause there as-is, and it'll
work. The for loop here is quite literally a drop-in replacement for
the if...elif...elif, even going so far as to allow the same else
clause.

for keyword,action in command_list:
if command.startswith(keyword):
action(command)
break
else:
do_general_action()


Moral of the story: there are two ways to do a linear search (or linear
sequence of tests): either an unrolled sequence of if...elif...elif
clauses, or a rolled up for loop with a break. Either way you do it,
you can tack on an else clause for when you don't find anything.


Carl Banks

BJörn Lindqvist

unread,
Sep 30, 2006, 3:05:46 PM9/30/06
to pytho...@python.org
> How do you transform this?
>
> height = 0
> for block in stack:
> if block.is_marked():
> print "Lowest marked block is at height", height
> break
> height += block.height
> else:
> raise SomeError("No marked block")

def get_height_of_first_marked_bock(stack):


height = 0
for block in stack:
if block.is_marked():

return height
height += block.height


raise SomeError("No marked block")

height = get_height_of_first_marked_block(stack)


print "Lowest marked block is at height", height

Yes, this transformation is one line longer, but the control flow is
much easier to understand. In general, using the for/else clause mixes
the retrieval and the usage of the element. Consider this:

for item in list:
if somecond(item):
A) do something with item
break
else:
B) exceptional code when somecond() doesnt match anything in list

The code that you write in the positions A and B really are misplaced.
They arent part of the iteration of list. The two tasks, find item and
do something with item should be separated.

def find_item(list):
for item in list:
if somecond(item):
return item
return None # OR raise an exception

item = find_item(list)
if item:
A) do something with item
else:
B) exceptional code

This is, IMHO, much better style.

--
mvh Björn

MonkeeSage

unread,
Sep 30, 2006, 7:01:31 PM9/30/06
to
BJörn Lindqvist wrote:
> The code that you write in the positions A and B really are misplaced.
> They arent part of the iteration of list. The two tasks, find item and
> do something with item should be separated.

I think it is useful to have them joined. Consider a contrived example:

for i in (1,2,3,0,5,6):
try:
print 10 / i
except:
print 'Error in data'
break
else:
print 'Data processed cleanly'

Yes, you could use a flag variable instead:

done = 1
for i in (1,2,3,0,5,6):
try:
print 10 / i
except:
print 'Error in data'
done = 0
break
if done:
print 'Data processed cleanly'

...but that is not as clean imo.

Regards,
Jordan

0 new messages