On 2004-03-26, Peter Seibel <pe...@javamonkey.com> wrote:
| Anyone have any stylistic preference for one or the other? (I guess
| the practical difference is just trading a type-error in for a
| no-applicable-method error if withdraw is ever called with a
| non-numeric second argument.)
A third possibility would be to use CHECK-TYPE:
(defmethod withdraw ((account account) amount)
Now if you call WITHDRAW with a non-numeric AMOUNT, the debugger will
"The perfection of art is to conceal art." -- Quintilian
You must Sign in before you can post messages.
To post a message you must first join this group.
Please update your nickname on the subscription settings page before posting.
You do not have the permission required to post.