In article <email@example.com>,
Elias Mårtenson <loke...@gmail.com> wrote:
> On Wednesday, 19 September 2012 12:29:20 UTC+8, Teemu Likonen wrote:I like FILTER not because its meaning is self-evident but because it's a
> > RG [2012-09-18 11:26:26 -0700] wrote:
> > > Personally, I think the right name for REMOVE-IF-NOT is FILTER.
> > Personally I wouldn't know if FILTER means REMOVE-IF or REMOVE-IF-NOT.
> If we're talking about a hypothetical rename that will never happen, here's
universal convention in the functional programming world that filter
means remove-if-not. But KEEP-IF is good to.
Or we could go with DONT-REMOVE-IF-NOT-NULL.
You must Sign in before you can post messages.
To post a message you must first join this group.
Please update your nickname on the subscription settings page before posting.
You do not have the permission required to post.