padding / innerMargin

10 views
Skip to first unread message

Knu

unread,
Nov 21, 2011, 10:06:41 AM11/21/11
to Arbitrary XML Rendering - http://axr.vg
http://axr.vg/spec/chapter/91

"innerMargin" should be renamed "padding" which is familiar to anyone
who ever used CSS.
If you really want to keep the margin concept, in the very least
"padding" should become an alias of "innerMargin".

Discuss.

Zisu Andrei

unread,
Nov 21, 2011, 11:54:37 AM11/21/11
to axr-...@googlegroups.com
Hello,

Indeed, the padding is more familiar, and it is intuitive enough.

Why are you no using the spec repo, Funcod? 

Andrei

Knu

unread,
Nov 25, 2011, 12:39:32 PM11/25/11
to Arbitrary XML Rendering - http://axr.vg
This alias addition or renaming should have a wider support.
So I am posting it here to collect opinions, critics and (more
importantly) +1s.
IMHO issues are there for complicate stuff.

Zisu Andrei

unread,
Nov 25, 2011, 1:02:41 PM11/25/11
to axr-...@googlegroups.com
Funcod, please post all the details, so people would know everything about this.

Allan K Jensen

unread,
Nov 27, 2011, 12:37:01 PM11/27/11
to Arbitrary XML Rendering - http://axr.vg
Aliases could be very confusing I think, they would need a good reason
to exist.

Example:

Your co-worker always uses padding, you use innerMargin. You add
inneMargin before hes padding, nothing happens, you then later after
almost ripping all your hair out see the padding.

Knu

unread,
Nov 27, 2011, 5:29:14 PM11/27/11
to Arbitrary XML Rendering - http://axr.vg
I don't wanna have to type "innerMargin" every time I need "padding".
These long camelcase names make absolutely no sense for such basic
properties.
Renaming will do then.

On Nov 27, 6:37 pm, Allan K Jensen <allankimmerjen...@gmail.com>
wrote:

Allan K Jensen

unread,
Nov 28, 2011, 2:17:12 AM11/28/11
to Arbitrary XML Rendering - http://axr.vg
I agree.

Zisu Andrei

unread,
Nov 28, 2011, 4:12:37 AM11/28/11
to axr-...@googlegroups.com
It seems reasonable enough. I agree with you guys.

Jeff

unread,
Nov 29, 2011, 3:12:43 AM11/29/11
to axr-...@googlegroups.com
I'm fine with using the names I'm used to from CSS. Aliases are always a source of confusing in any programming language and should only be used in carefully considered situations. I don't think an alias will be of any help here. So I'd like padding aswell.
Reply all
Reply to author
Forward
0 new messages